Player stops working after a while

Hi Guys,

tho i’ve been checking out this forum as well as many websites on the internet i can’t find an answer for my issue so therefore I’ll post it here and maybe you guys are able and willing to help me.

I’ve bought a WD tv live player a few weeks ago. After upgrading the firmware and setting everything up i used the machine for the first time. It was all working beautifully - all the files (.mkv etc etc) worked and i was a happy man. But after a few films/days i noticed that the player did not play any files anymore. normal mkv wich before worked perfect now would not work. That little round arrow you see popping up real quick when you start up a new movie? it does not go away. 

I tried resetting the machine and updating it, i tried resetting it without the update. botch cases no result, after a while it just stopped working again. In the end i swopped the thing around at the store and set up my new player. tried everything and it all worked up in till…

yet again, after a few hours it does the same stupid thing. I really don’t know what to do here. On the internet i stumbled upon people who have trouble keeping the thing working during a film - i have no issues with that. It just does not want to play any files anymore. 

Im getting to the point wheren i just want to throw the stupid thing out of the windoe, i don’t think that’s how a purchase should make me feel, should it?

Please help!!



Try disabling the Media Library, and see if it works. If not, then try deleting the .wdtv directory that the player creates in your storage device’s root directory. Make sure that you disconnect and reconect the device to the power outlet after performing each of the changes I described.

Thanks for your reply.

I tried both your steps but it still does not work. Do you maybe have a different solution?