MBL won't connect to router

Front light is solid green-- Link light on back is yellow, activity light is blinking green

 (Update: after leaving my device unplugged overnight, now the front light goes back and forth from blue to yellow)

But my MBL doesn’t show up in the DHCP client’s list on the router, and I’m unable to access it. I tried plugging the device directly into my laptop, but the device doesn’t show up as a shared drive.

I read there’s been severeal problems with the firmware update… I didn’t update the firmware manually (though it notified me that an update was available) but I suppose it’s possible that it updated automatically?

I’ve tried the usual steps (unplugging/re-plugging, paper-clip reset) to no avail. What else can I do to troubleshoot?


Dude, I’m sorry to tell you this but if the front LED is stuck from yello to blue then the drive can’t wake up and it won’t show up until it does… You’ll have to call WD for a replacement.

Could some of these problems be happening because some people are not shutting down their MyBook Live NASs properly?  Like simply pulling the plug?

Since I am unable to access my drive, I am unable to shut down the drive properly.  However, I have followed the alternative instructions from the manual for when regular shutdown is not possible. (wait for light to turn solid, unplug ethernet, wait 60sec, unplug power)