My Book Live access issues - No LED - No IP


I’ve had a perfectly working MBL (3 TB) for almost a year now, and had no problems with it. I always upgraded the firmware regularly and maintained a sound networking environment. 

The other day, I had to restart modem/router (as I routinely do), so I shut down the MBL via the dashboard: the shutdown was successful. After I restarted the modem, I plugged the MBL back on, and the problems started! 

I have no more working LEDs on the front panel (used to work perfectly fine, in spite of what I read on several threads here), no more IP address that I can reach (I have searched for it via both wireless and Ethernet networks, even plugging it directly to my macbook pro… I tried the arp -a command… nothing), no more dashboard access, no more quickview, and I obviously don’t see the drive in my finder or explorer (I have tried both with PCs and Macs.)

The drive seems to spin (I hear and feel it humming), but I have the impression that it’s ALWAYS spinning. 

The lower LED on the back (near the Ethernet port) is a fixed green, and sometimes the upper one blinks green as well.

I have read through and through this forum and on the user manuals… and I can’t seem to find an answer. Can somebody please help me?

Thanks in advance!

"I shut down the MBL via the dashboard: the shutdown was successful. After I restarted the modem, I plugged the MBL back on, and the problems started! "

Ok, so how did you restart the MBL? You said you shut it down and plugged it again. Was that the power or the network port you unplugged?

Unplug the power cord, wait 1-2 min and plug it again. Have a feeling you did not power up the MBL after shutting it down. It has not power button, and if not front LED, it means the device is off, see the manual for the LED status.

Currently mine is off with power plugged in. No front LED, in hte back, have one solid green and other one blinks once in a while.

Now, you cannot connect directly to a laptop, unless you are an advance user and have a DHCP server on it. So this is a meaningless test.

BTW, no need to shutdown the MBL just because you are rebooting the router/modem.

I have had no front LED on my mybook live for well over a year. I had read other issues of this going out not long after someone buys one.

I am having the same issue i can hear the drive start up and the lights on the ethernet port are blinking but my router doesnt show the mybook live connected and i cant see it mounted on my computer. 

I dont know what to do since i cant access it. I did hold down the resest button while starting but that didnt change anything.

The drive did get dropped on carpet the other day but worked since. So i dont think that is the issue but maybe it is.

I of course had already unplugged and plugged back the power cord. 

I had already connected my MBL to my MBPro a couple of  times, it keeps the last DHCP address the router gave him and works like a charm. I did it to do quicker copies of big files (instead of doing it via the wi-fi). 

The front LED is DEAD, not OFF, plus, as described, the disk is spinning (continuously) and the the back LEDs are working. The MBL is, therefore as ON as it can be right now. 

I shut down the MBL because my router is really bad (ISP mandatory, before anyone asks to change it :)), and arbitrarily gives random IPs when restarting. 

also tried resetting it, keeping the reset button pressed while re-plugging the power on for 7 seconds… nothing. 

I wonder, after switching off the MBL did you switch the power supply off at the socket outlet?

I ask this because these small ‘power pack’ power supplies are really little ovens. The internal components get very hot and cook up, after a while they become u/s. It is not unusual for them to continue working whilst the power is permanently on, but sometimes they do not come fully back to life when they are powered back up. Sometimes there is enough power to let a disc drive partially spin, but not enough for the disc and the internal the electronics to work at the same time. The leds on the back may be flickering because the device at the other end is actaully supplying power back up the ethernet cable to the ethernet chippery inside the MBL. Just a thought.

I did not think about that!

How can I check this? Should I try another , power compatible power supply?

It would certainly be worth trying a substitute powers supply if you have one of the right spec. The MBL supplied psu has a DC output of 12volts, supplying 1.5A. If you have an alternative you will have to make sure the connector is the same size as the one on the MBL and that it is marked that the centre pin ( or in this case the ‘hole’) is the positive voltage.

Otherwise you could buy one from your local small electronic supplier store, take your existing one with you so that you will ensure you get one of the correct electrical and mechanical spec.

My unit is barely a few weeks old and so I have measured the output voltage with my test meter. It is 12.2 DC volts. (rather than 12 DC volts). But it is not at all unusual for the voltage to be slightly higher than the written spec. But this voltage is the ‘off load’ voltage because the plug is in your hand rather than in the MBL. It is likely this voltage would drop when the unit is actually in use and supplying power. If the power supply is u/s then it would drop to a value much less than 12 DC volts. But the problem is of course that under normal conditions you cannot take the unit apart and get inside to measure the’ on load’ voltage. (I used to be a professional electronics engineer and taking these units apart, repairing them, and glueing them back afterwards was second nature to me but it is not really a DIY job).

Looking up a suitable replacement on the website reveals that a suitable replacement with universal/interchangeable connectors could be bought for under £15. Not expensive if that is the cause of your problem - but how to be sure? Not easy, so I hope your problem ends up being software related.

I should finally mention that with my MBL unplugged from the power supply, but still connected to my router I did not have any flickering green or yellow leds on the rear of my MBL, so in my case that does tend to eliminate the possibility of them being powered back up the cable from my router.

Thanks for all the info yellowtriumph, I will surely try this as soon as I get home. 

I will keep you posted! 

Unfortunately this was not the issue. 

After testing the power output of the stock charger (it was a steady 12 V throughout my tests) and a new one that a buddy loaned me, the issues are still there. 

Any other tests before I send it back to WD? 

Thanks in advance!