Stuck on blue light, not functioning

I googled and I searched this forum. The internet is full of “help! My Mybooklive is stuck on blue light (with an occasional yellow blink) and I cannot conect to it!” threads, but they are all unresolved (except for those that end with “I took it back to the store”).

I have that problem. Since yesterday my drive has been on blue light, with an occasional yellow blink, and no computer can connect to it - not through the wireless router, and not directly with a cable either. It simply does not show up.

I have tried unplucking it, waiting, starting up again. I have tried shutting the computer off and turning it back on. Same with the modem. The problem is clearly the hard drive.

I have also tried resetting it with the button on the back. Just like it has been reported in some of the many other threads on the topic: It doesn’t work. It simply does not reset.

What is the problem?

(and why is it still unresolved in all the threads?)

Taking it to the store is not a solution (and I have had it for more than a year, so warranty is probably out anyway).

And taking it apart should really NOT be required (and I will only try that if someone can give me good reasons to and careful instructions).

Surely, there must be a (simple) solution? This happened all by itself al of a sudden.

1 Like

when you log into the router’s admin panel, do you see the device listed in the list of connected devices?

holding the reset button on the back for 4 seconds will set the MBL back to DHCP, maybe then it’ll connect.

No. It is not listed in my routers “connected devices”.

I have already tried resetting the drive with the reset button on the back. It doesn’t work - everything stays the same, and it shows no sign of resetting.

not to sound overly simplistic, but did you try a different cable?  Maybe get a fresh cat5 or cat6 cable?

Olemartin wrote:


Taking it to the store is not a solution (and I have had it for more than a year, so warranty is probably out anyway).


The warranty on a MyBookLive is typically 3 years, so you might want to verify your warranty if you can’t get the problem resolved otherwise.

Yes, I have tried with other cables.

Unbrick can be your last choice if you don’t want to bring it back to store.

I did it last weekend and worked fine for me. note that warranty will be invalid after.