Map network drive windows 10 help?

Hi all,

This is probably an easy one for you but I am totally struggling here.

Long story short I had to revert back to factory settings on my PC & for the life of me when I select map network drive it can’t find the PR2100 I have on the network.

My wife’s laptop is the same & it’s driving me crazy it used to be as simple as click map network drive & it would appear & you would assign a drive letter.

I made sure that in the network settings that you can share/access networks, I have also tried to type //wdmycloud/users etc but that also doesn’t work.

I do remember I had this issue a few months back & the // worked but it had to be word for word what my path was, only thing is I can’t find the exact path so I can just copy & paste it into the box. Really could do with some help.

I can’t speak to the Windows aspect of your question, but one step that seems to often prove useful in resolving connection issues: have you assigned your PR2100 a >static< IP address on your LAN? If not, take a look and see if you can … and then see if you can mount it using its explicit IP address.

Thanks very much for the tip is it easy to do as I’ve never really fiddled about with stuff like this. I know it should just “work” but it’s clearly not at the mo.

I do use Fixed IP but I am still using WD access and it works on my OS3 AND OS5 NAS units

Using Windows 10 64 with latest Feb 2021 updates on a 2 year old system.


Yes it has been deprecated " refers to functions or elements that are in the process of being replaced by newer ones

So far WD just says it is gone or not supported so no idea if something newer is on the way ?

Ahhh see I used to have WD access but couldn’t find the download link for it at all. That would make things easier. Honestly they are really making things hard for customers these days.