Macs: Turn your Wifi OFF if you are getting slow speeds via Ethernet

So I’ve been playing with my new Macbook 12" Retina and my Macbook Pro 13" and have been making observations; I’ll be keeping only one of the two, although it would be nice to keep both.

UPDATE WARNING! Even though you think you have properly set up your service orders and your ethernet Gigabit shows active on top, you may still be running under WiFi speeds. I’ve tested this over and over and over again and have been caught running at wifi speeds while doing mass copies and it isn’t until a half hour later, doing other stuff, when I notice that my copying is still copying.

Although Wifi is just great for most usage, like surfing the net, copying one or two files and even a folder of photos which usually take a few minutes, don’t depend on Wifi to do your full backup. Incremental backups may be ok, but don’t backup a 128GB of data on wifi only; it can be done but it would be exasperating.

With my Mac purchases, I also purchased a few different attachments
USB-c to ethernet gigabit - good speeds giving me about 60-70 MB/s read/writes

USB to ethernet (Apple) apparently this seems to be a 100Mb/s ethernet so don’t expect fantastic speeds from this. Go purchase one of the USB3 to gigabit ethernet adapters out there. I’ll be returning this one for sure.

Thunderbolt to Gigabit ethernet - just a wonderful cable as there are not that many thunderbolt devices so might as well use the thunderbolt adapter for this purpose.

So I have my cloud drives mapped and I have been putting these MacBooks to sleep, on and off, as I played around with them. Testing out how fast they stitch 30 photos together and so on. Just a side note that I’m surprise that the new Macbook 12" retina which has a 1.1Ghz core-m turbo to 2.4Ghz is faster than my Mac Mini 2010 core 2 Duo at 2.4Ghz.

So the My Clouds stayed mapped no matter what I do, so if there has been any doubts on el capitan or even WD, I can verify that everything works as it should.

Until I plug in the ethernet adapter… and copy files… to find…

estimated one hour to copy…

“what the”… doesn’t Apple have this priority thing on their network preferences?

So to ensure a troll free forum, please turn off you Wifi if you plug in your ethernet, otherwise you will get Wifi speeds and you will be probably posting on this forum complaining to WD on how slow the Cloud is and be a troll like someone recently who wasn’t really a troll but he looked and acted like one because he was really a troll in real life but didn’t know it.

You would be too if you didn’t turn off Wifi and had your expensive ethernet cable on… and it took an hour just to back up 10 gigabytes of data.

My two cents as an Apple User…

Surely it automatically selects Ethernet over WiFi if you plug in an Ethernet cable and it detects a valid connection…?

1 Like

There is no “Surely” :stuck_out_tongue:

Yes, you would think that it would choose or even test which one is faster and thus go with it, but no.

I have verified this effect multiple times now… several times by accident and once to validate the reality.

If you open the network preferences you can choose which one is on top, but… it makes no difference.

I plug the ethernet cable in… wait till the network preference shows a connection and the ethernet is on top… then I drag and drop a bunch of files of 2 or 3 GB and voila, it is still going through wifi.

So deactivate wifi… and everything runs as it should.

If you are wondering perhaps I should give it more time to figure it out. My Mac Mini had its wifi turned on after I used the migration assistant (the tool that copies my user data and apps over to my new Mac). This was where I noticed the use of the wifi even though my gigabit ethernet is permanently connected. Priorities shows ethernet over wifi.

Not everything “just works”…

Burn the heretic…!

Not always. I’ve seen similar on Windows PC’s some times where the computer gets confused on which network adapter to use when both an Ethernet and WiFi are connected to the same network. Even seen it happen when there are two Ethernet ports are connected to the same network and on the same subnet. For simplicity sake one should disable WiFi if connected via Ethernet and vise versa if it doesn’t happen automatically by what ever software on the computer handles that.

it is usually the pc fanatics that causes problems as illustrated here :stuck_out_tongue:

a man of all religion :stuck_out_tongue:

This issue has nothing to do with Macs, or PCs; both are affected… I have had only laptops for years and they all are connected to my wired network 98% of the time and Wi-Fi is off. It is SOP to keep the Wi-Fi circuit turned off when using wired connection for all kinds of reasons One or the other but not both.

Amen :stuck_out_tongue:

Understandably that this is a “No Brainer” or SOP; turn on one or the other.

I’ve found that with a PC laptop I would want it wired but with anything Apple I prefer it to be naked with no wires attached :stuck_out_tongue:

Apple encourages you do just that go wifi AC. In fact for boxing day sale I got an AC wifi router on order for only $44 at Bestbuy. I’ll will be using this ultra fast wifi router with my new Macbook.

Now back to the ethernet cable. The thing with Apple we actually expect things to “just work”, like plugging in a ethernet cable automatically turns off Wifi or prioritizes the ethernet. They do this with the iPhone where if your wifi is weak it will use your 4G. So this does comes as a surprise that it doesn’t automatically prioritizes or turns off wifi for you or something to that effect.

I do see a lot of Apple users complaining about their time machine speeds and I suspect that they are backing up their macs via wifi and if they do plug in a cable thinking that it should give them gigabit speeds, they might be surprised like I was that gigabit is not automatic :stuck_out_tongue:

I use a Win 8.1 fast laptop PC, and my network is powered by a quality Asus RT-N66U gigabit router and gigabit network switches throughout our CAT5e wired house. I have one of the highest speed internet connections, and get up to 122Mbps on on wired PCs. and on my iPhone 5c using 5G signal speedtest registers 80-90 Mbps depending upon conditions.

My MyCloud DL2100 is rated for 115MB/sec transfer speed, and I regularly get 113 MB/sec and occasionally see 114 or 115 momentarily for wired file transfers.

So, yes, I have gigabit network speed and know it. Which brings me to say: if I had an Apple laptop it would be wired, not wireless, most of the time, unless I could prove to myself that a wireless connection is faster.

Most people, I believe, are better off using wired connections when possible, because it uses wires, not ethereal wireless radio waves that are subject to all the hazards/interferences radio waves are exposed to.

System Preferences > Network > ‘Bottom Left System Cog icon’ > Set Service Order > Drag Ethernet Above Wifi

This works for me

Doesn’t work for me :stuck_out_tongue:

I’ve ensured that service order has ethernet above wifi.

  1. while on wifi, I mounted the disk.
  2. plug in ethernet cable,
  3. disk speed test is still wifi speeds

They renumber my lists, so I have to have some text in between lists otherwise it goes from 1 to 14.

  1. eject mapped drive

  2. remount drive

  3. gigabit speeds

  4. pull ethernet

  5. wifi speeds

  6. replug ethernet cable

  7. still wifi speeds

The only guarantee is turning off Wifi.

UPDATE WARNING! Even though you think you have properly set up your service orders and your ethernet Gigabit shows active on top, you may still be running under WiFi speeds. I’ve tested this over and over and over again and have been caught running at wifi speeds while doing mass copies and it isn’t until a half hour later, doing other stuff, when I notice that my copying is still copying.

I would attach my MacBook 12" to my desktop connections (monitor, usb 3 hub, ethernet gigabit, power) when I’m at my desk and theoretically it swaps over to the gigabit ethernet as I thought… that is until I check by running a "BlackMagic Disk Speed Tester to find that it is running WiFi.

One thing that may be different with other users is that my Cloud is semi permanently mapped, whether it is on Wifi or Ethernet thus it may have a preference to stay with the last known connection. Thus pulling it off my desktop connections will automatically switch it to Wifi since the ethernet connection is no longer there. However adding back the ethernet leaves the Cloud still connected on the Wifi until I turn WiFi off. It does stay on the ethernet if I turn Wifi back on.