SUPER SLOW transfer speeds using time machine, any solutions?

I have a macbook pro, using time machine over wifi and the tranfer rate is horrible. 

It took 5 full days to do my initial backup of 220Gig. That is crazy. My tranfer rate for all my subsequent backups are about 1 Gig per hour. 

I tried hooking up an ethernet cable to my mac directly to my wireless router, which is connected to mycloud with an ethernet cable, and that did not speed anything up. 

I found some pretty confusing video on WD website, but I don’t think it was addressing my issue exactly. 

I’d rather not have to connect via ethernet to do any backups, but will if I have to, so two questions: 

Is there a setting I can use to speed up the tranfer over wifi?

Is there something I can do to speed up the tranfer rates when I connect via ethernet?


You can try setting a static IP on the My Cloud.

Just an update, I followed this post and my unit seems to work. I posted the information on what I did.