Extremely slow (failed) time machine backup and then extremely slow (failed) factory restore

Hi All,

I was given a mycloud for xmas.  Set-up went fine, I upgraded the firmware.   My first task was to use Time MAchine on my new macbook pro OSX 10.8 to wireless create a backup.   I already accomplished a “wired” 100Gig back up to my external hard drive in about 30 minutes.

After 20 hours, my computer had only backed up 30 Gigs.   Thinking this was abnormal, I called support.   They said it was normal (still don’t believe that) and told me to do my first back up hooking up my computer directly.   I don’t have an ethernet port on my mac, so I can’t.   Even if I could, I was worried that at a rate of only about 1 Gig per hour, the mycoud would be useless. 

Support suggested I do a full factory reset.   Now, after 2 hours, my factory reset is only 20% complete.   Are these speeds really what I am to expect or is something wrong?

Thanks in advance!

Big backup and wifi are not a good mix.,  maybe if your router and mac are wifi ac but i suspect that is not your case.

A full factory restore could take many hours. 

I am backing my MacBook Air over Wireless-AC. Wireless data rate from Windows shows 702Mbps. The initial backup (about 500GB) went over in about 5 hours, I’d say.

So it is not super fast, but close to USB speeds.

1 Like

I have the EXACT same problem … 

New WDMyCoud 3Tb Drive (with updated firmware), MacBook Pro (16 Gb RAM running Mavricks); backing up over Wireless.

This I have tried this 3 times and have had NO success backing up using TimeMachine.  Each time the backup runs for 1.5 DAYS and then fails, barly making 5% of the 500 Gb bakup files.

Not sure what to do … WD should have some guidance on this … but I haven’t found any.

If anyone out there has any idea what the cause and/or fix might be … please share.



i have the same problem.

just bought mycloud 3TB and was trying to use it with the timemachine.

it is so slow :frowning:

i have about 600GB data to backup and it takes ages to copy everything across.

i’ve even switched off time machine and was trying directly copy about 100gb files to the mycloud and it is the same slow so i gues this is not a timemachine issue.

Simple you cannot use Mycloud for backup for large data over wifi :frowning: (unless you have some special router)

And I feel really dissapointed. Im a regular computer usser and don’t know much about routers,

I think WD should add this information on the product, that you can use it only with some special routers, otherwsie it is very slow.

and actually, if I want to do backups in the old fashion way, i would buy a normal usb disk. why to buy a wifi disk and connect it with the cable??

im just returning mycloud to the store…

I also just got my 3TB Icloud and the backup speed is a joke. Wireless it was impossible so I thought let me connect it with a ethernet cable to my 1gbps network and it is a bit faster but still way too slow. Backing up 500GB is a joke. I dont want to take my drive back, I want to smash it against the wall and see if it copies faster.

While it is true the WD Cloud do suffer from a few problems, mostly growing pains I would say, speed over either WIFI or gigabit ethernet is not a function or problem of the WD Cloud, just like the roads and traffic is not a problem with the brand new vehicle that you just bought.

There are no special routers, just routers that support gigabit ethernet, but there are AC routers that give you greater WIFI speeds but still not necessarily the gigabit speeds that we all crave over WIFI.

Another factor is the backup software that runs very slow anyways, but if you compare a USB 3.0 backup to a gigabit lan backup, then there are no comparisons as a USB 3.0 goes at between 80-140MB/s compared to a max speed of about 40MB/s on a gigabit network. Again, network speeds versus USB 3.0 speeds has nothing to do with the WD Cloud device.

Every single NAS/Cloud device will give you the same network speeds regardless of the device.

If you are having speed issues, first check out your network and that everything is running at gigabit speeds. End to end, starting with your router, you can eliminate all connected devices except your PC and Cloud. You should never connect old PCs that has only 100Mb network connectors to your router as this will slow down your whole network.

Check your network cards to ensure they are gigabit cards by clicking on properties. In Mac check system pref and network/advanced and hardware.

Max speed over gigabit lan is about 40-45 MB/s write and 70-80 MB/s reads for ALL network devices. This means a 733MB movie file should copy over to the Cloud in about 15-20 seconds. It will take 10 seconds to copy back the 733MB file from the Cloud. This is mostly true for any device you connect at the other end, including a PC with an attached hard drive.

For a Mac, even though you are on WIFI AC that has theorectical speeds of almost USB speeds, it will fluctuate and is not the best method for copying large amounts of data. There are $50 USB 3.0 gigabit adapters these days that will give you the gigabit ethernet that you need. Make the wired connection, then backup your mac on the first pass, then use the wifi for subsequent daily backups.

I hope this helps

same problem for me. this device is starting to ■■■■ me off 

same same same. but i tried time capsule first and returned that. extremely slow also. I would agree it has to be a matter of WIFI speeds and the huge initial backup.

Since the updates are hourly, daily, weekly monthly changes only then these are relatively small updates that can occour while we are sleeping etc. 

Has anyone tried using the time machine to backup to a USB3 external HD? I backed up about 500 gigs in about 7 hours.

And then copy this to the MYCLOUD by plugging the USB HD into the mycloud and draging and dropping into the timmachine folder on the mycloud? 

Will time machine then recognize the backup on the NAS and then only backup the applicable files over wifi?

Currently backing up the wifes Mac air or i would try this myself.

I will check in the morning and see if there were anyone brave and or foolish enough like myself to try it and see if it would work.  Or if there are some tech savy people that can say dont bother. 3 failed attempts at wifi backups took over a week to finially give up… (1. i screwed it up by starting a new back up, 2. Power went out, 3. I shut the power off while doing electical work and realized probaly at the speed of light what a bone head move that was as i pulled the switch. thanks all for your input.


Same problem to me. I had to backup 300GB but after 15 hours it has completed only 26…

Plus, I have the annoying problem that after a check of the backup Time Machine needs to make another one and delete the old one. Absurd.

It’s pretty foreign to me… this abyssmal level of Apple service and solutions for a problem they’ve created (poor desogn, engineering, etc) with Time Capsule backups… and it doesn’t really matter what we do!  They’re not fixing it, they’re not refunding the $$ on the expensive time capsules that don’t work at all the way they’re supposed to for us! The service people are useless… by saying “it’s normal” and to use an ethernet cable!!!

Isn’t this pretty outside the business model & integrity that Apple stands for?  Why are they continuing to sell the TC units if there are these problems?

WHy don’t they tell us an actual fix?

I’m actually thinking of going public with this… I’ve got tech conections at some national papers that’d bite on this!