MacOS mycloud home not in Finder

Hi there,

A few weeks ago I tried to perform a time machine backup onto my mycloud home. In settings I selected the drive and connected as Guest user.
Now Some time later I’m trying to acces my personal files on the drive but I can’t acces my private partition anymore. Finder will only show the Guest connection folder with my TM backup.
I tried to disconnect the time machine settings from the drive but it made no difference.
I have also tried signing out and back in to the WD app and even tried to reinstall the app.
Nog Finder won’t show anything anymore. Not my private files nor the time machine backup. It fully lost connection to the drive somehow and it won’t find it anymore. The Mac WD app does still see the drive and tells me it’s signed in and ready but clicking the drive does nothing.
On my iPhone and via the web I can acces the drive normally so the drive is working.

I hope someone can help me out.

By the way I’m running MacOS Big Sur beta I don’t know if that makes a difference, it used to work on here tho.

2 Likes

It doesn’t work on Big Sur unfortunately. And if the experience with Mojave is anything to go by, it won’t work till maybe January at best.

2 Likes

I update to OS Catalina 10.15.6 and since then Finder won’t show anything in OS Catalina, and Finder slowest, in windows, my iPhone and via web I can acces to drive and it is working.
OS Catalina incompatible??? 10.15.6 (19G2021).
I need help. Thanks

3 Likes

Same issue on my iMac running Catalina along with the added annoyance that my automated backups were prevented possibly by WD Discovery. After I uninstalled, no more backup failures.
Finder only shows guest account with time machine backup. Connecting as registered user does not work
pc, mobile apps, and browsers work, Only hassle on iMac, browsers have file size limitiation

1 Like

Hey all,
was this sorted Im still having the same issue now (April 7th 2021)
just wont open past the WDDiscovery app

Currently on mac os 10.14.6 mojave

Hi all,

Me to can’t access in the mac finder. But on web ok. I’m sure of my account user and password !!
Why … I bought this stuff !! I regret it very hard.