Mac can't read WD Elements

Hi everyone,
I hope someone can help me with this. I have a WD Elements 1tb which works perfectly when I use it with TimeMachine. However, I recently bought a new one (the exact same one) - just to have 2 backups just in case - and my Macbook doesn’t recognize it. I know I am supposed to format it for Mac via disk utility before I can use it, but this process also fails. I’ve tried erasing the drive and then reformatting it, I’ve tried different settings when reformatting - none of it seems to work. I followed the exact steps indicated on the drive’s manual. Can someone help me out with this? I’ve done my fair share of googling but most questions seem to be answered with the reformatting process in disk utility, which isn’t working for me.
Thanks in advance!

Hi cj94xx,

Just try to format the drive using Drive Utilities.

You can refer to the link given below for instructions.

Hi Alex,

Thanks for your response. I installed WD Drive Utilities but my drive doesn’t show up there either.

Hi cj94xx,

I am sorry there was some confusion, please check your personal message.

Thanks!

i have the same problem, i bought a new 5TB external drive and whenever i connect it to my mac running high sierra it says that it can´t be read in this computer, please someone help me!

I have the same problem - just bought a 2T elements drive. High Sierra OS. Never had a problem before. Please Advise ASAP. Followed all the instructions to the letter. Right now it shows up in disk utility as a greyed out “disk2s1” Every time I try to erase and format it fails and says that there is not enough space on device for requested operation.

Believe it or not I found the solution at Seagate: http://knowledge.seagate.com/articles/en_US/FAQ/007736en
The key was changing the View in Disk Utility.

1 Like

This is a GREAT piece of insight. I could have saved myself a lot of frustration, but for one little click on the SHOW ALL DEVICES. The WD Elements would not even mount or show up in the WD Drive Utilities.