WD Elements fails to format on Mac

Hi there

I have a WD Elements 2TO drive that I am trying to format for Mac. I went to Disk Utility and followed the instuctions but the formatting failed and now the drive doesn’t show in the Finder window. The drive does appear in the Disk Utility screen but this is no good to me as I need to be able to read and write to it.

My OS is El Capitan.

There is no way of partitioning it as it asks me Enable Journaling which is greyed out.

What in the heck do I do? I need this drive to send off some work to an agency and it is critical for me.


Just tried partioning plugging it into my wife’s Windows machine and it is now not recognized at all.


What happens if you completely disconnect the unit for 10 minutes before trying again? Is the unit not detected at all within Disk Utility? Not even the “First Aid” section?

Windows will no longer detect a hard drive that was partitioned with a Mac-specific file system unless you navigate to Disk Management, where the hard drive should be displayed as raw or not initialized.

I can see it in Disk Utility but nowhere else. Have tried leaving it uplugged but to no avail :frowning:

Feel very frustrated as I’m currently encoding a number of 4K time lapse files to go to an agency that sells my work.