Lost remote access to MBL, how to regain?

Hey guys, I have a MBL that I have been using for quite a few years so I am sure it is an older model number. At some point my device stopped connecting to the internet to be used for remote access. This was attempting to use the webpage login, or using the app on my phone. I have checked the device and all my accounts are in there and say connected etc, nothing had ever changed with my network or anything and one day I went to use it and it could not find it.

I recently moved and am trying to get it working again now and when I sign in and try to set up remote access on the mycloud website it does not detect a device on my network. I am able to access the device via share drive on my PC or going to the IP address for it yet any sort of remote access does not work or see the device on the network (despite it being there and able to be reached by IP or the webaddress for mybooklive).

Is this something I can get working again or is remote access completely broken on older devices? I have read things about SMB1 which I have checked and is enabled on my PC, though I am not sure how this would affect remote access from a phone or webpage since the device is connected directly to a router.

Would really appreciate any help getting this working again, or the knowledge that I am SOL and need to find a new device. Very frustrating when everything worked fine for ages and all of the sudden is shut off.

Did you go from iOS12 to iOS13? If so, try this:

Bypass HTTPS Validation in the My Cloud Mobile App by following the steps listed below to disable and Bypass HTTPS Validation in the My cloud Mobile App:

• Open the My Cloud mobile app
• Tap the 3-line menu icon in the upper left corner of the screen
• Tap “Settings”
• Tap on the words “App Version” 4 times very quickly to access the debug screen
• Tap on “Bypass HTTPS Verification” (Slider ON) to enable
• Tap “Done” in the upper left-hand corner of the screen
• Close and open the mobile app

if that doesn’t work for you, …

Force the My Book Live or Duo into Proxy Relay Mode by disabling network router UPnP or ensuring the My Book Live is Double NAT, located behind two IP address serving network routers.

Or / and

Open the mobile device internet browser and access the device using MyCloud.com web application. For instructions, please refer to Answer ID 4697: How to access a My Book Live and My Book Live Duo using MyCloud.com

Perry

I do not have the specific HTTPS option that you mention in settings.mine says “HTTPS for streaming” which is currently checked off… My device is not behind 2 routers assigning IP addresses it is just connected to one router, both back when it used to work and now that I have moved. I am not sure how to force it into Proxy Relay Mode.

When I try to sign in through the webapp, it just says “can’t connect to MyBookLive”. When I try to sign in through the phone app it says it can’t find the device. When I log into the direct webpage of the unit via IP, it says remote access is enabled and set up and connected to internet, yet cannot be found when I sign into my account…

If I don’t try to sign in on the homepage and I click “Setup MyCloud” it searches for a device on my network and fails to find anything. Really don’t know what to do aside from blowing the entire thing away and trying to set it up from scratch again or something but I do not want to lose anything. I also am pretty sure I had tried to wipe it and set it up again at my old house and still hasn’t worked since.