Cannot find the devie


I just bought MBLD yesterday. I installed it without any problem. And I successfully connected my old USB external drive to it. Everything worked just fine. I can access it by using apps/different laptops/web. 

However, over the night, I cannot access it at all. I’ve tried web UI and WD2 go app. Reset, restart…

I don’t know whether this is related to the Internet provider in my flat. In this network, if I want to use a device, I have to add the MAC address to my account so I’ll be able to use the device. I double checked the MAC address and I tried to delete it from the device list and re-add it so it will have another IP address, but nothing works. I just have no way to access the MBLD. The LED shows everything should work in order. So I suspect it is something wrong with the Internet provider.

Anyone has any opinion on it?


Are you saying you cannot reach it REMOTELY, or even from your own local network?

If it’s not working on the local network, then your ISP should have nothing to do with it. 

Try rebooting your router first, then reboot the MBLD.

If that still doesn’t work, then press the reset button on the back for 4 seconds so that it resets the network configuration, and then try again  

Keep in mind that the default network configuration is “automatic,” which means it’s expecting your router to provide it an IP address via DHCP.

If it’s a REMOTE problem, then you won’t be able to access the Web UI from outside.  The MBL doesn’t allow that.