Lost IP from MyCloud. How do connect again?

Hey everyone,

I recently switched my WD MyCloud from DHCP mode to static IP, because I wanted to connect from outside the Local Network via VPN or so. But now that´s not the main problem anymore. I red in a forum that it´s an IP above the DHCP IP pool required, so I gave it 198.168.178.1 as far as I remember. Before that, the IP was 192.168.178.50

Now I can´t connect to MyCloud anymore. not with the old IP, not with the new one. Also the connection via wd2go.com fails. I now moved the whole thing to another House and hoped it would connect properly but it didn´t. I tried the setup tool again, which didn´t found the device, i scanned the whole IP range with another tool and i even tried arp -s “New_IP” “Mac_Adress” in CMD to set a new IP. Access denied was the result, although I don´t know if its due to the NAS or a Windows/admin permission thing.

I know it´s a real stupid problem, but I hope someone can help me!
I thought about taking the HDD out of the NAS an try to backup the Data, i don´t want to loose anything. But I don´t know if it´s a good idea to remove the HDD and if its even possible…

I´m thankfull for any help!

Hannes

Have you tried doing a 4 second reset? Removing the drive will void the My Cloud warrantee.

http://support.wdc.com/KnowledgeBase/answer.aspx?ID=10432

If you gave **198.**168.178.1, (198 in the first block), your PC need to be in the 198.168.178 network too.

If this is a typo and you gave **192.**168.178.1 then this is the same IP-Address as your FRITZ!Box has and therefore you have a so called IP-Address conflict with your FRITZ!Box. To solve this you need to attach the My Cloud direct to your PC and set the PC’s IP to static IP too, like 192.168.178.201 with subnet 255.255.255.0 to access the My Cloud Dashboard UI. Then you can change the Static IP of the My Cloud, recommended 192.168.178.202 and above until 254.

Wow that was so easy I didn´t even think about resetting it… Thanks a Lot!

@Joerg_A no there was no IP conflict.

Now that I´m already here, does anybody know how to connect to MyCloud from outside my local network? Besides the Desktop app of course. I want to add it to Windows Explorer as an network device/storage, but not just here, but also for example at my parents house.

Thank again

The only official ways to access the My Cloud remotely is with the WD Desktop, the MyCloud.com web portal, using FTP/SFTP, and the My Cloud apps for iOS and Android. If you have not already done so you should read the My Cloud User Manual as it explains how to access the My Cloud remotely (see Chapter 8 Accessing Your My Cloud Device Remotely): http://www.wdc.com/wdproducts/library/?id=439&type=25

There used to be a way to map a drive remotely through the Web2Go.com (now MyCloud.com) web portal but WD removed that “feature” when they upgraded to the OS3 firmware. Feel free to voice your complain in the following thread as others have done.

https://community.wd.com/t/re-enable-remote-drive-mapping-through-mycloud-com/134944

Use the My Cloud app, although I can also access the My Cloud from anywhere using the app for my Asus router called AiCloud, because it sees all shares on my network through the Internet. Many newer routers have an app like this.

If you want to access the MC from your parents’ house on their equipment, then that’s another story needing a new post.

I am glad you figure it out, however, I would double check your range, since it is not a private IP range.

Unless you are in Canada and work for Saint-armand Mcgill University: http://whois.domaintools.com/198.168.178.0

Almost for sure it was a typo… :grinning:

WD Desktop App works, but I don´t like it cause there´s no thumbnail on pictures and many other features i miss from normal explorer. Mobile app is ok, but doesn´t solve my problem. So FTP should do it right? That way i could link it directly to explorer as if it was in the local network. I already searched for it but couldn´t find a real good advice so far. I know, i just have to enable it in the settings, but what should i do in the Fritz!Box (router) here and on the other end?

@Shabuboy it´s now in dhcp mode and got a 192.168.178.usw IP, so it shouldn´t cause any issues so far.

It should be noted that FTP is NOT a secure protocol. Your use name and password are sent unencrypted and in the clear. If you want to use FTP you have to enable port forwarding in your router to pass traffic on the FTP port (21) to the My Cloud. See your routers documentation on how to enable port forwarding. The user would use their My Cloud User name and password to log into the share’s they have permission to access.

It is possible to configure the My Cloud to use SFTP which is a more secure access but it typically involves some editing of My Cloud firmware files via SSH to enable User access via SFTP. Instead of port forwarding port 21 for FTP, one port forwards port 22 for SFTP. Just note that there are additional security issues when one enables SFTP access to their My Cloud. The user would have full access to the My Cloud drive and could potentially mess around with the My Cloud OS files.

https://community.wd.com/t/sftp-setup/95350/4

https://community.wd.com/t/how-to-setup-sftp-on-my-cloud/152297

1 Like

I did the same thing just this morning. My Cloud page was opening slow VERY SLOW so I was messing around and changed the Gateway and the DNS server to my modem and hit DHCP and BAM could not connect either with my LAN IP for router which was on 192.168.3.1 because I changed it to the modem which was 192.168.1.254
It didn’t see it connected in either device. So I took a paper clip hit the button on the back of the Cloud device to reset it.
Next went back in to the router and found it changed from 192.168.3.50 where I had it set to Static to 192.168.3.15
So, went to 192.168.3.15 in the address bar and it went to the Cloud page and quickly set it back to Static where I had it to begin with at 192.168.3.50
But this is what fixed my problem when hitting the DHCP once I had it set to Static in the beginning.

Hi @ron351

Is 192.168.3.50 within our without the DHCP range of your router?
Best would be to use Static Lease within the DHCP server of your router - if supported by your router.
Then you could set the My Cloud to DHCP and the router will set always the same IP address.

Static DHCP Lease is a feature that most routers support. A DHCP-Address is bound to the MAC-address of a device. Whenever this MAC-address requests an IP via DHCP, it will get the defined IP-Address by the DHCP-Server.

This will exclude all headaches around Static IP address setting in client devices, sum up the benefits of static IP address wiht the simplicity of DHCP. And you have to cope with one device only (the router) instead of fighting with several client devices and the network.