Logins no longer work after update to OS5

I updated to OS5 last night and went through the update process, setting passwords, local users and cloud access and it seemed to be working fine. Left it overnight while it was indexing. This mornign i try to login in over my network and neither my user or the admin user will work, both come up saying ‘Incorrect credentials’. I tried using the old passwords i had before and the new passwords i set up while updating and same for everything. I tried logging in via the cloud and that said the password was wrong, reset it and got in via cloud access at least now but can’t get in to the dashboard now and doesn’t seem to be any way to reset the password?

Also after several failed attempts the login page says ’ The user name or password you entered is incorrect. Visit here for assistance.’ which doesn’t work.

1 Like

Same thing here, I updated my My Cloud EX2 Ultra to OS 5, followed all the instructions and now can’t login through Web browser (edge or chrome) or the mobile apps (iPad cloud os 5 app). I’ve tried everything and am at a loss. I’m regretting updating…

2 Likes

Thanks for reporting the issue regarding the reset password link. We will get that fixed and I have posted the article that it links to below. Before resetting your password, please and verify that you can access and see your content using Windows Samba or macOS Finder, web and mobile app if you enabled Cloud Access.

It’s highly likely the unit is indexing which will consume higher than normal CPU and Memory until the process has completed.


Hi SBrown,

Thanks for replying. Yes i can see my stuff when i get in via the cloud access using a browser on PC. I’ve tried using the App on my phone, andriod, but it just says it can’t find a internet connection and won’t let me do anything. It has a connection though as everything else uses the internet fine on it.

Just to follow up, used the link you supplied and done the 4 second reset and got access back now.

App still isn’t working though, can confirm i’m using the new OS5 version from the app store.

Let’s use the same thread. Same issue here…
I updated my EX4100 to the new version yesterday. I updated my admin password and my cloud password.
I fortunately kept my access passwords so I can see all my files on all my home devices, but…

  • I cannot access the admin settings site;
  • The reset password link is not working;
  • I logged into the cloud site yesterday, I cannot do it today.

My SSH access to the device is working, Can I change my admin account password trough SSH?

I saw the link for device reset but I’m not brave enough to press it. If it resets all passwords and configurations it will take ages to restore the previous (before updating) device access and performance.

What are the options for account password reset?

1 Like

@Hades12 The “Forgot Password” link is currently not working and will be fixed in the next firmware release. It points to the reset KBA listed below.

1 Like

I am having the same problem too. I got the email that stated “The local network user password for tony was updated”. I have updated to My Cloud OS 5 and have a My Cloud EX2 Ultra device. The admin id was changed to tony and worked successfully before upgrading from OS3 to OS5.

After updating to OS5, I can access it via the mycloud.com web site and My Cloud 5 mobile app. The device is still indexing, so I can see some of my content of my shares. Just to test that I have read and write access to my tony share, I created a new “test” folder. It was created, and I successfully deleted it too. So I have proved I have read and write access using the My Cloud 5 mobile app.

But when I try to logon to the My Cloud EX2 Ultra using a web browser by entering the IP address within the web browser within my local network, I am getting “Incorrect credentials”. I get redirected to “https://device-local-ea384887-e684-43e9-8a10-d7db07cdfa19.remotewd.com/”. I enter in the Device username of tony and the updated password with no success. I get “Incorrect credentials” message. The username defaults to “admin” and I enter the updated password again with no success, same “Incorrect credentials” error message.

Also within my Windows desktop using File Explorer, I try to access my “tony” shares I am getting the Windows 10 Security window asking to "Enter network credentials for tony. I enter the updated password but get “The user name or password is incorrect” error message. I can’t access my shares defined to the “tony” admin id.

This is the only userid that I updated the password and is the admin id. All the other non admin userids that are using the “old” password that were not updated can still access the Samba shares. So the problem is with the “tony” admin account is with the updated password.

2 Likes

Hi @SBrown , can you please comment on the “Docker not available on OS5”? This has a huge impact on many WD customers right now. Thank you.

Thank you for your prompt replay, SBrown.

I pressed the reset button and hold it for 4+ seconds. I tried it several times and waited for more than a minute but nothing happened… and suddenly the NAS started restarting, Unbelievable…

Then when I entered the NAS IP into the browser I was redirected to https://device-local-{some-GUID}.remotewd.com/ and I had to enter my admin credentials… not the “New password” screen that I expected…
Great job, WD!!! The reset password procedure is not working either!!!

Important! If you want to enter your new admin password, disable your internet access (unplug the main LAN cable), but keep your home network connected… If you do that when you are browsing your NAS IP you will see the NAS internal config page, not the “cloud” one, so the “New password” screen appears.

I hope this discovery will help others in their change-password nightmare.

@SBrown: I managed to restore my admin account. I disabled completely the NAS cloud access and converted “My cloud” device into on-premise NAS device. :rofl:

Great news and an update to my post.

I followed the instructions provided in the link to the article “How to Reset a My Could EX2 Ultra Device”. I did Option A: 4 Second Reset successfully.

After the My Cloud EX2 Ultra rebooted, I used a web browser (Chrome) and re-entered the local device using the redirected link “https://device-local-ea384887-e684-43e9-8a10-d7db07cdfa19.remotewd.com/”. Using the admin id, the next screen allowed me to reset my password. I set the password to the previous PW before the upgrade. I was able to access the My Cloud EX2 Ultra, logout, and log back in using my changed admin userid “Tony”

Most importantly, within my Windows 10 desktop I was able to map to my Tony shares that were defined within the My Cloud EX2 Ultra.

My conclusion, following the article to Reset the password resolved the problem that previously gave the “Incorrect credentials”. I am back using the My Cloud EX2 Ultra after the 5.04.114 upgrade.

All is good!!!

1 Like

Hi Hades12,
please try to use your admin password you used prior the OS5 upgrade.
I had similar behaviour, see my threat

1 Like

+1

I have a similar issue. I have an oppo bluray, before os5 accessed my wd4100 drive over network ok, never needed login credentials. Now demands username & password, rejects all local account credentials.

1 Like

I have exactly the same problem with my Oppo Bluray player, I can’t login to the drive direct via the Oppo or via the Oppo App on my iPad and iPhone, as my username and password are not accepted, however, both work using the WDCloud app.

I upgraded late Wednesday and four days later indexing is only at 29%, why is it taking so long?

@ChrisV56 @PeterSu The following article will help depending on how your Oppo Blueray Player is accessing the My Cloud. IE: Twonky DLNA or Samba (SMB).

1 Like

I have a WD MyCloudMirror drive. Until I updated to OS5 this worked perfectly with my Oppo DVD player using the Oppo app and with my iPhone and iPads using the WD app. Since updating some two weeks ago I have haven’t been able to use it properly at all. I used the forum and was advised to use Twonky as my Oppo could not see any files at all. When I go to configure Twonky it takes me to ip address 127.0.1.1 which it can find and open. A friend managed to find an IP address which let me into Twonky, However, not all my folders and files appear, so the main sound files that I want to play on the Oppo in a General Folder I can’t play as it can’t see it. Photos and Videos are listed however photos are not shown and only the sound of the video is playable. On my iPads and iPhone using the new app for OS5 I have been able to at least access photos and videos, however, I believe there was an update and today I have the wheel of death and the app does not display any files. I am not technical and was really pleased with the way the drive and system worked prior to the update. I cannot tell you how disappointed I am with an update which has messed everything up to point I can’t use anything. To make it worse, just before I updated I had placed an order for a 28TB drive. I am hoping that has the old operating system on as I have no intention to update that. As I say, I am really disappointed to be in this position where something that I found worked really well I can no longer use.

Thanks for reporting the issue.
Please Sign Out and Sign In the My Cloud OS 5 mobile app to resolve the issue.

1 Like

Many thanks for this.

Is there any way that I can roll my Mirror drive back to V3 software? On my Oppo App which worked fine with Twonky I only seem to see Video, Music and Photo files, not the files on my drive, which I saw with V4/ Also, the video have no picture and the photos while listed have no images. For my new drive I am sticking with the V3 software as loaded. Many thanks.

@SBrown,
Can you please describe the method you use to convert “MyCloud” device into an on premise NAS device?
I have been working on access to my NAS for 2 1/2 days but Windows 10 will not accept my credentials when I tried to sign into the MYCLOUDEX2ULTRA.