Local folder missing, help

Hello everyone!
I have always used the My Home Cloud from windows locally. But suddenly the folder corresponding to my local user has disappeared from the network folder of the my cloud.

In the Network section of Windows File Explorer I get the folder \MYCLOUD-xxxxxx, and inside it I get the two folders Public and TimeMachineBackup, but I don’t get the folder “username” where all my files were.

From the local network access menu it says that local access is enabled, but I don’t see my files anywhere.

Let’s see if someone can help me.

thanks !!!

1 Like

I have the same problem. Via the web interface I see all my folders and files but via the Windows Explorer only the Public and TimeMachineBackup folders are present and are empty.

This may have something to do with owner-user accounts and ‘Clear Device Settings’ (CDS). One other My Cloud Home (MCH) owner has reported missing user files after doing CDS.

This minimal 2 line description doesn’t describe the possible scenario.

It is possible to have different owner versus user accounts for the web app (browser) and local access.

If you read the instructions, there are several limitations that must be observed:

  • The Device Owner CANNOT enable local network access for guest users.
  • Local network access must be enabled by each guest user.
  • Local network access using Samba (SMB) does not include access using the Mobile, or Web.
  • A maximum limit of 10 users can enable local access per device.

So the only way to access local connection with MCH have the risk of loose my data?

That’s a great information…

Each day I’m more and more disappointed with this product :face_with_symbols_over_mouth:

Most users came to this forum and dole out a minimal description, then expect some kind of a revelation. That is probably not going to happen.

The answer provided earlier was that there was one case of user losing guest user folder when he did ‘Clear Device Settings’ under some special circumstances.

In order to help others understand this special circumstance, can you confirm that you did ‘Clear Device Settings’? and was this a guest user account?

I have the same problem which just appeared today. As at yesterday, I could access my local drive. I have not changed any settings or Cleared Device Settings and no guest accounts have accessed the drive. Please help. I hope this is not another big glitch we have to suffer! :frowning:

Sometimes users just assume every symptom has the same cause.

Are you saying only the local user folder is missing or you are not able to access the MCH at all? There is a difference as described by the original poster:

For now, the only thing I can suggests to all users afflicted is to try to use the webapp (browser) to backup your data (to USB) if possible and file a support ticket with WDT.

WD Technical Support team for best assistance and troubleshooting:https://support-en.wd.com/app/ask

I have the same problem as well.

I can access all of my folders via the app.
I have My Cloud Home setup as a mapped drive on Windows 10.

I see Public and TimeMachineBackup but none of my personal folders.
I do not see these 2 folders in the app or when I log in online so I presume they are default folders.

I only have 1 user on My Cloud Home.

It’s as if I need to grant access to myself to see my folders.

My desktop and MCH are connected via the same LAN. I can also only see the same 2 folders when I connect via the IP address.

I have not cleared Settings and do not want to disconnect unless necessary as mapping the drive was crazy hard (and I am an IT professional). It was super finnicky.

Thank you for your more detail description than the other ‘home’ users. Often home users skimp on details which make any replies less than optimum. That is why most users will benefit from filing a support ticket.

The next question is whether you see ‘none of my personal folders’ in any other PC or Mac from the same subnet?

This is normal behavior. You won’t see those two Public shares in the web app or mobile apps.

Good info.

Based on this, If you try another PC, you may get a different result.
If you change the state of IPV6 in network settings for your PC’s network adapter, you may get a different result.

This condition may have nothing to do with the My Cloud Home.

Cannot see network shared folders until i change the state of IPv6

Steps provided by support.

This resolved this issue for me.

  1. Login to your device locally.
  2. Toggle “off” Local network access.
  3. Clear device settings. (As the primary user. I only have one user account.)
  4. Wait until you are prompted to log back in. (May take hours or even days.)
  5. Login
  6. Toggle Local network access back on.
  7. Create a Local user name
  8. Create a local password.

Go to Windows File Manager, click My Computer, click Map a Drive.

Follow the usual process.

Use the local user name and local password.

This worked as an IP address add or as a mapped drive.

Hope it helps someone else!

1 Like

Thank you for the update and report of a positive resolution.

Unfortunately the original poster did not report back whether he did perform ‘Clear Device Settings’ and we are not able to resolve whether this is a wide spread problem with a similar or identical solution.

Edit made to my steps. It was CDS of the primary user. I do not have any secondary users.

Clear Device Settings clearly states that files will not be lost.


1 Like

My issue was resolved by clearing device settings.

I didn´t like that solution but I can´t do anything more

1 Like

Thank you for reporting back on your findings.

You can mark your post as a solution or mark the dionbarb post as a solution. That will allow more MCH owners to see the findings.

I can confirm that the following steps resolved this issues. My environment:

MacBookPro with Sonoma 14.2
MyCloud Home 10TB with firmware 9.5.0-186

This resolved this issue for me:

  1. Login to your device locally. (http://mycloud-xxxxx.local/static/ → different to the above mentioned solution)
  2. Toggle “off” Local network access.
  3. Clear device settings. (that’s in the menu and took me some time to understand)
  4. Wait until you are prompted to log back in. (took some minutes in my environment)
  5. Login
  6. Toggle Local network access back on.
  7. Create a Local user name
  8. Create a local password.

I could then connect to the MyCloud Home from Mac Finder, log in with the new user name/password. It now shows correctly “TimeMachineBackup” and “Public” as before (though “Public” came up recently with the issue) and “user name”. My files can be found again under the “user name” folder.

I am having the same issue as OP, but doing CDS and creating username and password either the same as before or new one still didn’t resolve the issue for me! I can see my user folder in the app and online, but not on Windows. What can I do now? This happened after I changed my PC, but with the same boot SSD…

OK, so now it works.

Steps I added further was to clear the Samba Cache / Keys and restarting explorer:
To clear SMB credentials on Windows, you can try the following steps:

  1. Press the Windows key + R together to open the Run box.
  2. Type in rundll32.exe keymgr.dll, KRShowKeyMgr and hit Enter. This will open the Credential Manager.
  3. Check if the credential is stored here. If so, remove it.
  4. Alternatively, try ending the explorer.exe process in Task Manager and running it again. Press the Windows key + R and type explorer.exe and hit Enter. This should clear the session credentials 1.