Can't access user folder on mycloud home

Not sure when this started but my user folder is not visible in win 11 explorer. I can only see public and timemachinebackup folders. I can login through the app and through a browser and see my files but it has disappeared in win 11 explorer. Not sure if it was a windows update or a WD update that broke it. Any help would be appreciated.

1 Like

Open Windows Credential manager and check that you still have a cached user and password for the My Cloud Home (MCH) private folder, this is assuming you do have a MCH (has white top half, silver bottom) and that you have already enabled local access. If not, create one or delete old, create new.



RickPohlReplied on April 9, 2023
Report abuse
ReplyIn reply to RickPohl’s post on March 28, 2023
I just wanted to let everyone know that at this time I have fixed my problem going on two weeks now. I just added a username and password to the window credential manager. I was told to remove any username and password in credential manager but at that time i had no username or password in credential manager. Now I do and everything is working. Thank you for your time.

I tried adding new credentials but did not work. For some reason Win 11 no longer sees my Local user name folder, it only sees public and timemachinebackup

Disable and re-enable local access. Open Windows credential manager and delete old user and redo add user.

  • Enter a local user name and password for the private share.
    Click Add Access to grant local network access.

The login and password is different and unique from the Western Digital account and is only used for local network access.

You can also try using a Windows Microsoft Local Account to log into Windows instead of the online account Microsoft forced upon users. Note that this is different from the WD MCH local user name and password.

When I try to disable local access I get an error

An error occured
Internal server error

Unfortunately that is all too common. This error occurs when a Win or mac OS tried to write to the My Cloud Home (MCH) file system and resulted in permission errors on the MCH file system. This requires a ‘Clear Device Settings’ (CDS) on the MCH itself. Please note that there are at least 3 reports from users that in a multi-user environment, a guest user’s data may be missing after this CDS procedure, so please back up important data which one should do regularly anyway before performing this.

Notice how it described this as non-destructive, but some users lost data but some of them were able to recover it.

  • The device will reboot and re-index the content.
    This may take few hours to few days or more to complete.

  • Device will show as Device Offline during reboot.

  • The page will refresh and go back to the dashboard login after reboot.

  • Erase does not remove network shares, guest users or data.

  • Sign into the Dashboard.
    Enable local access again.

1 Like

I am trying to figure out how to backup all the files on mycloud home to my pc before I try clear device settings. There doesn’t seem to be any feature available for this.

The cheapest and fastest way is to backup the MCH is to get a multi-terabyte external USB hdd and plug it into the USB 3 port of the MCH. This is well documented in the owner’s manual as well as the KBA

Pardon my language, but HOLY ■■■■! This process FINALLY worked for me. Thanks. I am still super frustrated with the various connectivity issues I have experienced, but I’ll keep the Duo for now.

1 Like

Finally, backed up to my MYBook drive and cleared settings, the drive is still checking contents and got back my access in explorer. Thanks for all the help.

1 Like

Hello all, After going in rounds to resolve the frustrating disappearance from the network, I detached the drive and reattached it again, and I can only see one folder. When I logged in from my mobile to the app, I discovered that it is INDEXING and apparently this process takes days depending on the data stored on the drive.

I decided to wait till the reindexing finishes.

Now after 24 hours, I started seeing other folder showing, however, the performance is still very very slow.

I believe leaving it to complete the indexing, I will at least be able to see my stored data and then maybe I am able to back it up somewhere else.

I tried the TerraMaster NAS, and comparing price to value, it is a very good low cost alternative.


I removed the Windows Credential although it was set up correctly, and set it up again. I still get the “not accessible” message as posted here. Any other suggestions? This has been going on for months. I have no access to the user folder, only public and timemachine

Unfortunately you are posting irregularly on different threads and expecting someone to follow the specifics of your My Cloud Home dysfunction. I would in general suggest getting tech support in a chat session, describe your setup more fully and escalate from there.

There are several posts in this thread you are reading (above) that resulted in successful outcomes and you can study them if you think you are having similar problems.