Only Public and TimeMachineBackup folder visible with Local Access

Hi there,

I’ve been using my MyCloud Home device for a long time with Local access, but for some time I can see only my Public and my TimeMachineBackup folder, which I never used, they are empty. But I’d like to access my main folder that was accessible under my username.

Accessing from Windows and Mac is the same. I can see all the files in my browser, but not in local access.

I tried everything, what is the solution?

Thank you,



Support Search Results | Western Digital

Thank you, but I can’t find the answer here. I did all the steps but it didn’t help. A lot of information there, but not about my problem.

Nobody really knows what you know and what you have tried, but there are several posts in this thread that resulted in successful outcomes and you can study them if you think you are having similar problems. Scroll down to the 2 solutions.

That thread also suggests to users looking for help by contacting WD support when they can’t find the solution.


I have the same problem. I tried using other PC and other Operating system and same problem.
Honestly It will be the last WD I purchase, only problems.
Services discontinued, no access… and the support either doesn’t respond or takes a long time to resolve.

1 Like

Thank you for your support. It’s not easy to find the threads about the same problem I have. However, now I tried to follow these solutions, but none of them helped. Some of them I’ve already tried, except disabling local access. Unfortunately, this doesn’t work, because when I want to disable it I got an internal server error message. So I will try to contact WD.

Have you tried disabling en re-enabling local access? For me it didn’t work but it would be good to know your experience.
On Monday I will try WD support…

Internal Server error has always been a sign of permission errors requiring ‘Clear Device Settings’ on the My Cloud Home. It is clearly stated in that thread and various other threads about Internal Server error.

Remember the caveats listed in that thread and quoted here above and remember to backup the My Cloud Home.

Me too, this last product MCH
App and web browser cannot access the documents, only local access is available. The log is sent to WD support. But the email with their was blocked by their email system. My different emails were used. One moth passed, no any further solution.

Thank you, I noticed that, but at the moment for me it is very difficult to backup more terrabytes of data. I think I will have to buy an external hard drive…

Yes, I tired and I get the same message “internal server error message”. As several people has similar problems, should be something with the operating system, not with the box.

This description above is the opposite of what was described by the original poster who said:

@Tenglang If you assume all errors have the same cause, then you will get lost pretty quickly. You should post a detail description of the error(s) in failure to access through the webapp in a new thread.

In general, failure to authenticate will prevent a My Cloud Home user from accessing their documents online. This could involve the WD authentication servers, the browser version, browser tracking cookies, the router UPnP and firewall or failure to install security updates on mobile or desktop OSes.

Please see

as well as the recent thread

@NoPlex , After seeting safari and web browser, it works now, thanks a lot for support. It was so strange, it was working in January, but MCH was powered up after a long holiday in March, it can not be accessed. I guess the WD server changed someting.

1 Like

Same Problem here, since a while I can only access Public and TimeMachine folder. I have tried to disconnect and reconnect local access but without success.