Missing (Vanished) folder in Network but still there online

I have two MyCloud Home drives - one with general files and the second drive had a folder with music in it. They were both accessible through my normal network. Recently, for some reason, the folder with music has vanished on the network (public and timemachine folders on that drive can still be seen and accessed). The other drive still has all its folders accessible through the network. The music folder can still be seen and accessed through a browser.

I don’t think this is a PC issue, I tried accessing through a separate laptop and it still doesn’t show. The files can be downloaded via browser but, as WD does not let folders be pulled through that is looking to be laborious. The files are still accessible via Plex, also.

I really want to be able to 1) see and access the files locally again or 2) somehow be able to batch pulldown the folder to another drive.

Any help would be gratefully received.

1 Like

Just to add, I have tried to find the folder through acronis and whilst the drive shows as part of the network, that folder does not.

Right. This is a common network permission problem sometimes associated with third party programs and/or OS such as macOS that mutilate (yes, really) user file and folder permissions on network drives such as the My Cloud Home (MCH).

Most MCH users on this subforum would have known about this because it is duplicated in about a dozen different threads.

The Western Digital Tech support solution is to have a Dashboard functionality that resets all user files and folders permission without deleting user data (hopefully).

Thank you so very much, worked like a charm.

@Taliesin Thank you sharing this post. Finally my problem got resolved too. :slight_smile: