Live Hub not loading after firware update to v3.12.15

#1

Updated firmware to v3.12.13 using download to USB ‘manual’ method. Placed USB stick into front USB port. Followed instructions. Update progressed as per on-screen instructions
Completed Step 3 “updating firmware”.
As defined in the user guide the unit closed itself down BUT then did NOT restart/reboot itself. Waited over 1hr - nothing.
Powered unit up manually using on/off button. Disc is spinning and unit is sending a display to the TV - WD (large letters) WD TV Live Hub (small letters) - basically the ‘logo’ startup screen. That is as far as it goes in the ‘boot’ sequence.
Prior to my firmware upgrade attempt I recall the unit used to say something about ‘Loading Mochi’ after which the main menu would appear.
I have tried connecting the unit to my Windows 10PC via USB cable and also directly to my router LAN1 port + Ethernet cable - unable to map or ‘see’ the drive. Also tried ‘Reset’ button on unit. Nothing works. Unit remains ‘stuck’ with the logo screen display. Any idea anyone ??

03/03/18 - as the unit is no longer supported by WD and zero replies on the discussion group I bought a USB to SATA/IDE drive adapter , removed the drive and connected to PC via USB + adapter. My laptop successfully ‘sees’ and maps the SATA drive - TV shows and movies ‘directory’ structures and files all still in place. I booted the media player without the disc in place, the logo screen comes up and the light on the USB stick containing the new firmware ‘blinks’ as though the ‘chip’ bootstrap process is kicking in but then it all halts - same as before. Given the disc is ‘all OK’ my guess is that there is some sort of failure between the bootstrap firmware and the ‘bulkload’ of the Mochi operating system to the hard disc - unless of course Mochi O/S is all held on the chip - which probably means the firmware upgrade somehow corrupted the chip. I will keep the 1TB of disc and simply download movies from the inet to it and chuck the rest of the unit in the bin - after taking out the battery.

#2

sorry to hear :frowning:

yes, the operating system with Mochi is stored on the NAND flash memory.

a WDTV Live Hub in working condition will still function even without the internal hard drive connected (there will be an error message stating the hard drive is not connected … but pressing “ok” button on the remote control will cancel the message and the WDTV Live Hub will continue to function as per normal)

Have you tried inserting a USB Stick with “Rollback Firmware” on it ? … dunno if it will make any difference, but worth a try

#3

Hi Joey - take a bow sir - knowing the Mochi O/S is completely on the chip was a big help - even better your tip to try a rollback. I tried to go back to 3.11.10 - didn’t work, same result as previously. Then I tried to roll way back to 2.02.16 (listed as Original release but I know for sure the release on my box was even earlier than that). Presto - it worked exactly as the rollback webpage instructions indicated. Before I attempted the firmware upgrade I asked WD support if I needed to do incremental upgrades they advised “no, simply take the latest” - have a feeling that incremental is the way to go.
Massive thanks … and if u r ever headed to New Zealand let me know and we’ll have a cold one or two. Cheers Pete

#4

Happy to hear it’s up and running again, and happy to help a neighbour … i’m Australia :slight_smile:

#5

Hi Joey - struggling with another ‘issue’. Whole reason I thought to upgrade the firmware was in preparation to connect the box to the internet via wireless USB adapter. I checked the ‘compatible adapters list’ went into Noel Leemings and got the tech guy to recheck the list to see what they had ‘in store’. I bought a D-Link Wireless N Nano USB DWA-131 H/W Ver E1 F/W Ver 6.02.
The adapter came with an install CD - which I was not expecting. I tried simply plugging in the adapter to a USB port on the media box then turned the box on. I watched the led on the adapter - the box did not read the adapter. I then tried setting up the adapter on my laptop using the install CD. It all worked and I was able to connect to our home Wi-Fi using the adapter, rather than the in-built card inside the laptop. I then put the adapter back into Livehub - nothing. Any ideas ???.
Only ‘gotcha’ I can spot - on the compatible list it says ‘not listed’ against the version with an asterix footnote about adapter manufacturers and versioning.

#6

Sorry, never attempted using Wi-Fi Adaptors since i have a lousy signal in my room. (Using a Netgear Ethernet Over Power Adaptor)

WD TV’s are pretty picky and limited compatibility with Wireless adaptors

Referring to the “not listed” notes at the bottom of the page … *If your Wireless adapter has a revision number on the box, the product may be a newer revision than what was validated and may not work.

And the problem as i see it … the WDTV Live Hub (released in 2010) and final firmware was released in 2013 (3.12.13)

Your D-Link DAW-1313 H/W E1 … which i assume is revision “E” is definately what i would class as a “newer version” … released 1st January 2017

http://support.dlink.com.au/Download/download.aspx?product=DWA-131&revision=REV_E&filetype=Drivers

EDIT: One thing i did experiment with on the WDTV Live Hub … to get a “Wireless Connection” was using a Range Extender i bought from Aldi.

The range extender has an Ethernet Port, so i plugged it into the power and connected an ethernet lead from the range extender to the wdtv live hub’s ethernet port … and i can’t remember exactly how i set it up (it was years ago) but i do remember it did work. There was no driver disc or anything with it … it was all plug’n’play

Have a vague memory it worked fine for my local network and file/media sharing … but it couldn’t connect to the internet.

it looks like this …

Anyways, sorry … i’m not much help with your problem :frowning:

#7

Hi Joey thanks for coming back - ever thought of getting a job with WD - comprehensive response or what!. Yup, looks like the adapter I bought is too ‘new’. No worries - it isn’t ‘crucial’ to hook into the inet (although I might just have one go at wiring it directly to the modem using an Ethernet cable - something to do on a rainy day). Thanks ever so much for all your help.
Cheers
Pete

#8

Sorry for coming late to the party and asking a question but the topic says v3.12.15 and you mention you updated to v3.12.13. I updated to v3.12.13 ages ago via a network connection not USB. Now, every time I attempt to update from the SETUP/System options I get a message about no network connection (or something like that) although I’m connected and can get at network data and YouTube videos.
What IS the latest firmware version and how can I download it?
Very much appreciated.
Thanks, Dan.

#9

Well, I found the firmware versions in the SUPPORT section and v3.12.15 is the latest even though it’s from 2013. I know it’s no longer sold but they could at least update the firmware when bugs are found.

Does WD have a new/supported replacement product? I bought a Live Hub for both of my children and was wondering what to get if any of our boxes breaks.

Thanks.

#10

WD have discontinued it and it’s reached it’s EOL (End of Life) years ago … they can’t keep supporting a product forever.

No … WD no longer make Media Players.

There are numerous media players available to choose from today.

What you decide to get will depend on what you need it for, and how much you want to spend.

#11

Thanks so much Joey. I guess I’ll see what’s out there when the time comes. Till then it’s still going strong.

#12

i still have my hub, and running perfectly since they first came out, but i also an Ebox T8 V TV box
that runs kodi s912 2gb 16gb that has has internal room for a 2.5 hd or ssd, also a Zoomtak UPlus box.