WD Live TV Hub won't connect to Network

I have been using a WD Live TV Hub on my home network for years, The firmware is 3.08.14 which I updated (through the device settings) to many years ago. Because of some behavior problems that arose, like the spinning arrow goin on forever before opening a video file, I decided to reset the WB Live TV Hub using the pinhole on the bottom of the unit. After resetting, the device works fine provided the Ethenet cable to the router is NOT plugged in. If it is plugged in (as it was prior to resetting) it goes to the WD screen and “loading” under it, but never loads. It will after a few minutes fail and retry over and over again,
I looked through this form and read the thread on a similar situation, but everyone is talking about either updating or falling back on the firmware. Both something I’m not familiar with.
If anyone has seen this problem and has fixed it please let me know,
Thank you


I resolved my issue based on another thread. The firmware has to be rolled back, and to do this you need a USB stick. To summarize the procedure:

  1. Download the below
    [http://download.wdc.com/wdtv/Rollback_wdtvlivehub_2_08_13.zip ]
  2. Expand it onto a USB stick. Ensure it is not in any folder.
  3. Look into the USB stick contents and open the .VER file with notepad.
  4. Change the “2” to “4”. Any number higher than the current firmware version will work,
  5. Start the WD LIve TV Hub without Ethernet cable or USB connected,
  6. Go to settings>system and ensure the Auto Detection of new firmware is set to ON.
  7. Insert the USB. You will get a “Do you want to synchronize?” message, choose CANCEL.
  8. The the auto-detect will create a bright orange NEW FIRMWARE option in the menu. Proceed to update the firmware,
  9. After going through several restarts, eventually it will complete.
  10. Now go to Settings>system and do a restart.
  11. Once all booted up insert the Ethernet cable. Go to System>Network to check.
  12. You can keep the firmware as is at 2.08.13 (System>about). Or update to higher if you like.

This is how my problem was fixed.

1 Like

Hello Ken.
I have same problem whit my TV Live Hub when conected to my net via ethernet, it worked fine for years, but from a few weeks starts the problem
My firmware version is 3.12.13
I’d donwload the firmware, but when check .VER file it says 3.08.13, not 2.08.13 as the link
Thanks in advance

Hi! I have written about this topic here (in Spanish). Maybe it can be a solution to your problem. Good luck!

Go to this page. It gives full instructions on rolling back the firmware.
Also gives links to all firmware versions.
I used the 2.08.13 and it worked for me.

Sorry, please go to this page:
How to roll back the firmware on a WD TV Live Hub Media Center, WD TV Live Streaming Media Player, or WD TV Media Player

There‘s no need to tamper with the FW at all. It seems, WD has shut down essential web services your WDTV Live Hub is polling during system bootup and then eventually fails to coonect with these resulting in the endless Loading screen or continuous reboot.

To keep your box in your network, you must disable automatic IP address configuration (DHCP) and manually enter an IP-Address that fits your network. However leave gateway and DNS at to refrain the Hub from connecting to the internet (It won‘t work, trust me! So keep the box off the web until either WD resolves that issue with a final firmware or if your box stops working due to hardware issue!). Unfortunately this also means that the system clock will no longer be accurate and may out of sync by time.

“So keep the box off the web until either WD resolves that issue with a final firmware or if your box stops working due to hardware issue!)”

I seriously doubt WD is ever going to release a new firmware version for a long discontinued product.

Unfortunately yes I doubt that, too. Am just glad that I can use a new 2TB disk in the WDTV Hub (currently moving all my stuff onto that disk). So it‘ll work for some more time now (despite the rather nasty load failure due to missing web services)

Sad that WD has stopped supporting these fine players. They work well and are simple to use even if they are 10 years old. I bet if WD would release a modern 4K capable player with Mochi and it‘s wide support of media, these players would sell as good as their famous portable disks (have about 10 of them and none failed so far!)

Well since this topic still is topmost, maybe a WD representative will have a look at it and suggest a WDTV Live Hub SE (that supports 4K etc.).

Bet that WD would again do a fine job and bring out an awesome device…

Good morning Netspark1078, I have 2 WDTV Live HUb with the same problems and they are the only ones that really work for everything, I have modern 4k TVs and they don’t run everything, the most important thing that I admire in these our WDTV’s is that they are the only ones to play music in WAV DTS 5.1 channels, a pity that Western Digital ceases the production of these wonderful devices, nothing compares. Now this Firmware problem I’m trying to get him to give up trying to connect “maybe to a provider?” that no longer exists, and finally free access to your files, the way it is (keep it off the network) I don’t have access to it on other connected TVs, nor can I update your files.

1 Like

Enabling SMB in Windows10 features is the only trick that worked to let the WDTVLIVEHUB show again on my network neighborhood… (i was about to discard it)
I then mapped it to a drive (i.e “Z” or “X” …) to help go to its content if its name is not shown in Windows Explorer.
When it disappeared again the mapped drive shortcut helped … (instead of repeating the same SMB enabling / Disabling again …