Firmware not updating

Hello

I have a WDTV Live Hub.

A little while ago, I rolled back my firmware (the system tells me its 2.07.17) because the new firmware was not compatible with my wifi adapter.

I am now connected via ethernet and am trying to upgrade firmware but it is not working. I go through all the steps, and click OK at the “current version/new version screen” and the new firmware downloads and the system reboots, but when it is rebooted, it is still the old firmware installed and it’s like the whole process never happened.

I have tried both via ethernet and USB with the exact same result. I have also reset factory settings which did not help.

Any ideas?

First of all … you’ve posted in the Wrong forum (This the WDTV Live Streaming Forum)

You post belongs here (I’ve notified a moderator to move it)  http://community.wd.com/t5/WD-TV-Live-Hub-Discussions/bd-p/wdtvlivehub

so let me understand …

You rolled back your firmware to 2.07.17 because “New Firmware” is not compatible with your Wi-Fi Adaptor

and now you want to “Upgrade to New Firmware” to make your Wi-Fi Adaptor In-compatible again ?

ok, whatever  

And now you say after “Updating Firmware” the Setup > About screen is still displaying 2.07.17 ?

You are doing something seriously wrong.  (or not doing something)

(personall, i’ve updated from to 2.07.17 to newer firmwares and rolled back many times over the last 3 years … and in that time i’ve never heard of the “issue” you’re describing)

POST More Info:  eg. download links to the Firmware you are trying to upgrade to … detailed info on what you’re doing.

My guess is that you’re using a USB stick, and the firmware on it is actually 2.07.17 with the rollback code instead of newer code.  

Or, are you trying to update “Over the Air” (via internet)?

Hello

Sorry for posting in the wrong thread - if a moderator could move it, that would be great.

Yes, I am now upgrading because I will no longer connect the unit wirelessly, it will be connected via ethernet cable.

Yes, you have it right. The player goes through all of the steps of upgrading (ie. downloading the new software and rebooting, but once rebooted, it is still the same old firmware and the “about” options confirms it is still 2.07.

This is the one I’m trying to upload too.

http://www.wdc.com/wdproducts/updates/?family=wdfwdtv_livehub

The steps I’m taking are to load the device, scroll over to the “update firmware” option and click “ok” when it asks if I want to update the firmware.

Oddly, when it “detects” the new firmware, it detects it as 3.0.8, not 3.12. Not sure if that’s relevant.

I’ve also tried updating it via usb, by extracting the files into the “front window” of the usb, plugging the usb into the device and trying to update that way. Unfortunately, that doesn’t work either and it goes through the exact same steps with the same result.

Hopefully that helps someone and thank you for taking the time to respond to me.

i have tried both “usb” and “over the air”. both have the same result.

really odd :neutral_face:  try this “force update” … follow each Step Exactly

1. small flashdrive (2,4,8GB … no larger) formatted FAT32 … completely empty

2. re download firmware 3.12.13 again (if you already have downloaded it proceed to Step 3)

http://www.wdc.com/wdproducts/updates/?family=wdfwdtv_livehub

3. extract all 5 files onto the root of the flashdrive ie. No Folders

so you should only have these on the flashdrive

wdtvlivehub.bi2

wdtvlivehub.bin

wdtvlivehub.fff

wdtvlivehub.info

wdtvlivehub.ver

4. Open and edit (using Notepad)   the file  wdtvlivehub.ver

From this …

VERSION='3.12.13’
LOCATION='wdtvlivehub.bin’
PKG_LOCATION='wdtvlivehub.pkg’
ROOTFS2=‘wdtvlivehub.bi2’

To this …

VERSION='4.12.13’
LOCATION='wdtvlivehub.bin’
PKG_LOCATION='wdtvlivehub.pkg’
ROOTFS2=‘wdtvlivehub.bi2’

close … and save changes

5. Before inserting the flashdrive … check the detect New Firmware setting is “On

Setup > System > Auto Detect New Firmware > On

6. Power off the WDTV (Press and hold Standby button for 5 seconds … switch off at the mains power)

7. “Safely Remove” the flashdrive from your PC and insert it into the front or rear usb input on the WDTV

8. Power On the WDTV

9. New Firmware should now be detected “New Firmware” notification will appear in the Home Menu. Press OK.

(it will say 4.12.13 … don’t worry, ignore it)  … press OK to proceed)

10. wait until finished  (it can take several minutes … it should not take longer than 10-15 min)

11. It’s also highly recommended after a Firmware Rollback (or upgrade) to do a *Factory Reset*

Setup > System > Device Reset > Reset All Settings Back to Factory Default

after doing the Factory Reset … check Setup > About again

If it doesent say 3.12.13 … then i’m at a loss  :confounded:

1 Like

Thanks for your detailed post.

i have gone through all of those steps exactly (with the exception of using OpenOffice to edit the text in the document as opposed to notepad as I am using a mac.

When I click the new firmware notification it says “Current Version 2.07.17, New Version 3.07.17. New firmware found. Do you want to upgrade?”

So basically, it seems to be recognising the new firmware as 3.0.17 for some reason. i’m completely confused.

And without the USB plugged in it recognises the new firmware as 3.07.17

Have been able to fix it.

I rolled back to 2.02 and then upgrading over the air from there.

All working great so far - thanks for your help

CharlieVersion6 wrote:

When I click the new firmware notification it says “Current Version 2.07.17, New Version 3.07.17. New firmware found. Do you want to upgrade?”

 

So basically, it seems to be recognising the new firmware as 3.0.17 for some reason. i’m completely confused.

That’s weird – since there never was a 3.07.17 update…

Anyway, glad you got it sorted.