Incomplete firmware upgrade

hi,

i have tried to upgrade to the latest firmware 1.02.17 (wd tv media player)

during the upgrade process i go this message “incomplete firmware upgrade. please check your network setting and restart the wd tv to try again. you can also use a usb drive to complete the upgrade manually”

after i press ok button i have checked the the current version in the setting menu and i can see the firmware is 1.02.17 but every time i restart the player it will try to upgrade the firmware again and give the that error massage. i tried to download the new firmware on a usb device but it didnt work. how can i force the wd tv to reinstall the firmware from the usb or is there a way to downgrade to the previous firmware?

regards,

ofek pere

1. small flashdrive (2,4,8GB … no larger) formatted FAT32 … completely empty

2. re download firmware 1.02.17 again (if you already have downloaded it proceed to Step 3)

3. extract all 5 files onto the root of the flashdrive ie. No Folders

so you should only have these on the flashdrive

wdtvmediaplayer.bi2

wdtvmediaplayer.bin

wdtvmediaplayer.fff

wdtvmediaplayer.info

wdtvmediaplayer.ver

4. Open and edit (using Notepad)   the file  wdtvmediaplayer.ver

From this …

VERSION='1.02.17’
LOCATION='wdtvmediaplayer.bin’
PKG_LOCATION='wdtvmediaplayer.pkg’
ROOTFS2=‘wdtvmediaplayer.bi2’

To this …

VERSION='2.02.17’
LOCATION='wdtvmediaplayer.bin’
PKG_LOCATION='wdtvmediaplayer.pkg’
ROOTFS2=‘wdtvmediaplayer.bi2’

close … and save changes

5. Before inserting the flashdrive … check the detect New Firmware setting is “On

Setup > System > Auto Detect New Firmware > On

6. Power off the WDTV (Press and hold Standby button for 5 seconds … switch off at the mains power)

7. “Safely Remove” the flashdrive from your PC and insert it into the front or rear usb input on the WDTV

8. Power On the WDTV

9. New Firmware should now be detected “New Firmware” notification will appear in the Home Menu. Press OK.

(it will say 2.01.17 … don’t worry, ignore it)  … press OK to proceed)

10. wait until finished  (it can take several minutes … it should not take longer than 10-15 min)

11. It’s also highly recommended after a Firmware Rollback (or upgrade) to do a *Factory Reset*

Setup > System > Device Reset > Reset All Settings Back to Factory Default

Thanks. It worked .