Firmware Updating

Hello, I currently trying to update my WD TV Live HD Media Player (WDBAAN0000NBK-00)

It’s currently running  Version 1.02.21 firmware. I noticed there’s been newer firmware and I  want to update to latest. However, each time I try to it gets stuck at 0% when I try with Ethernet or when I try with USB stick it gets stuck at the OK. Example. Tried via Ethernet (not wireless) doesn’t work. However first time I got this device that was how I updated the firmware and worked like a charm. I tried two different USB Sticks. Both different sizes and followed the “How to Install the Product Update” from the WD Product Update page. Not sure what else to do. Maybe doing a reset on the device? Or do I need to install the Version 1.03.49_V firmware before installing the latest or just going from what I have now Version 1.02.21 firmware to Version 1.04.17_V. Does that matter?


Yeah, you could try a reset.

IF you’re upgrading via USB, there’s no need to do a stepped-upgrade through versions.

If you’re upgrading via internet, it will automatically step through various versions to get you to the latest.

If I try to do the updating via internet. It gets stuck at %0.   However I used this method when I first got this device to do its updating with the firmware it has now. Also If I try with USB it gets stuck at the OK menu.   It just get stuck at both methods and doesn’t move. I tried a reset and that doesnt do anything either.

Also may I add, it does work. What I mean is I can play my movies, go on youtube. etc…

However cannot update the firmware.