Linux filesystems *NOT* supported by My Cloud?

System: My Cloud (single drive version, 6Tb)
Firmware: 2.11.140
Status: Configured, on my network, and apparently working. (Wow! What a concept!!)
Configuration:
Static IP, DNS, gateway, etc.
Device name changed to a name of my own choosing.
All media and cloud functionality disabled.
SSH enabled and working.
Turned off indexing by running the two commands mentioned in another posting:

  • /etc/init.d/wdmcserverd stop
  • /etc/init.d/wdphotodbmergerd stop

Tried attaching a 3T drive, formatted as ext4 to the USB port on the back - no joy

First:
I took the time to peruse many of the messages on this particular fora, and - aside from the occasional troll and/or people with an abysmal lack of manners :wink: this seems to be a very interesting group. The people on this fora seem to have a clue, are willing to help, (if asked politely), and seem genuinely interested in getting things running well.

For all of this, I thank you.

Issue:
When attaching any hard drive preformatted as ext2, ext3, or ext4, the system returns the error:

Unsupported File System
An unsupported file system has been detected on a USB device (vendor JMicron, model: JM20336_SATA__USB_Combo, serial number: 214DA8888888, file system: N/A, label: N/A). Please remove the USB device.
Monday, 2016 April 11, 7:09:45 PM Code:1121

It appears to work with the various flavors of FAT and NTFS.

Short of nuking it back to the stone-age with a full factory restore - do you have any ideas why this thing won’t access or mount a Linux filesystem?

I have already tried looking for the device in /dev.
If a supported drive is inserted, it appears as /dev/sdb1
If an unsupported drive is inserted, it does not even appear in /dev.

I tested this with a 6 gig USB hard drive by formatting it as ext2, ext3, and ext4 on a system running Mint 17.1. e2fsck on the Mint box disclosed that the drive was squeaky clean, (and yes I "-f"orced the fsck to run.), just in case the physical size of the original drive (3T) was the culprit.

According to the relevant instructions, the various flavors of the ext filesystem should be supported, and there is no mention of what the max USB hard drive size is.

What am I missing here?

Thanks!

Jim (JR)

It would really be nice if you could determine what filesystem it thinks the USB is format.

RAC

Have you tried removing the partition on the external USB drive, repartitioning then reformatting? It appears in certain cases the My Cloud doesn’t properly mount an external USB drive. In my case I had one USB drive the My Cloud OS3 firmware simply wouldn’t mount. Removing the partition, creating a new one, then reformatting solved the issue.

Another way to test is to use another USB hard drive or flash drive formatted for a Linux file system to see if that device is mounted.

One can see my experiences with one particular drive not being mounted including some log data at the following thread:

https://community.wd.com/t/this-is-absolutely-unacceptable/149432/8

You can SSH into the My Cloud. Then run “fdisk /dev/sdx -l” Under filesystem will be listed the filesystem type. Under ID is the number identifying the filesystem type. Replace the x with the letter being used for your USB normally it would be /dev/sdb. Tell us what the results are.

RAC

FYI - this post is supportive of all the folks wishing to learn and is not intended to refute your particular experience. Also I have absolutely no suggestion nor experience with which to aid you in finding a solution. I have found that WD support (albiet slow) is competent and willing to help.

I believe your title is a bit misleading … my experience with a 3 TB MyCloud [WDMyCloud v04.01.03-421 : Core F/W ] is it supports and successfully stores files originating from: 1) Linux, 2) MAC OS X, 3) Windows 7. I also have a 4 TB MyBook attached to the USB 3 port that is formatted ext4.

Since Linux is my primary OS I fully manage MyCloud without any of the WD supplied utilities for MAC or Windows.

@PJPfeiffer
I do not mean to offend, and you will notice that the terminal punctuation is a question-mark - the title is supposed to read more like a “WTF?!! This thing DOESN’T support Linux filesystems?”

Obviously it is supposed to support them. If it routinely did not - what with what the documentation says - there would be a wailing and gnashing of teeth like you’ve never seen! And yes, I know my /dev from my /proc. :wink:

@Bennor

No. I have not, and have no plans to - especially since this drive contains something like 3T of irreplaceable data! :cry:

What I have done is to take a different USB drive of much smaller size, nuke it, and reformat it as ext4, ext3, ext2, and NTFS. I also took a thumb-drive (formatted as FAT32 I think), and tried it. Formatting for the ext[x] partitions were done on a box running Linux Mint using mke2fs, and specifying the appropriate file-system. The NTFS format was done on my Win7 laptop. The only formats that were recognized were the non-Linux formats.

Huh? At least as far as /dev is concerned, the drive doesn’t even exist!

I have not been able to run that command as I have something like two-and-a-half days before I get shipped off to Europe (with this device in tow!), so I am doing all the copying I can by mounting it on my main server as an nfs mount. Once all that is done - if I have the time before I go - I will try that and report results. If not, I will try it when I get there and things settle down.


Oh. . . I just thought of something. . . .

Looking at the quote in Bennor’s post, I notice he’s having trouble with Toshiba drives, and pretty much all of the drives I’m using here are Toshiba branded drives. I think even the tiny drive is a Toshiba.

Could the brand of the drive be an issue?

Thanks for all the suggestions, I will try them when I get a chance.

Jim “JR”

Update:

While wandering around these fora, I ran across Bennor’s posts within the thread “This is completely unacceptable!

Interesting!

There is a lot of data there. In my case I have absolutely no problem mounting NTFS volumes at all, however the commands and logs he shows are interesting and worth a look.

Thanks!

Jim “JR”

If the drive does not exist, then how can it report that it has an unsupported filesystem?

RAC

For the record my post above contains a link to the "This is absolutely unacceptable! " thread so there was no need to wander around looking. :laughing:

While you may have reformatted the drive did you delete the partition first then reparation before reformatting? In my case doing just a reformat didn’t solve the issue I had to remove the partition on the drive, repartition, then format for the My Cloud to properly mount the drive.

As the logs in the “This is absolutely unacceptable!” that I posted indicate the My Cloud was seeing the drive, but was not mounting it. For what ever reason the My Cloud was treating it (NTFS) as a read only drive. You will need to dig into the logs (as I did) to see why the My Cloud isn’t properly mounting or seeing the drive.

OK, everybody - I have a few cycles to spare while I build up a Linux Mint machine to replace the Win-7 box that just died (yesterday).

I am puzzled. I try running the commands mentioned within a SSH shell in PUTTY, and I get a “no hablemos Engles, Senior!” message. . .

Viz.:

login as: root
(root's password. . .)

BusyBox v1.20.2 (2015-02-25 14:32:43 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

root@Storage2 root # fdisk -l
-sh: fdisk: not found
root@Storage2 root #  udevadm info -q all -n /dev/sdb
-sh: udevadm: not found
root@Storage2 root # fdisk /dev/sdx -l
-sh: fdisk: not found
root@Storage2 root #

OK, tell me what I’m missing here. Why am I not able to use the same commands YOU are using?

Jim “JR”

Probably because you are using the v2.x firmware versus others who may be using v4.x firmware.

Edit to add: The v2.x firmware may not have the same programs/services/modules that the v4.x has or have them in the same place.

OK. . . .

Yes, this box is running the 2.n firmware.

How do I fix this? Run “apt-get install everything” (laughing!)

Seriously, if I can’t run the seemingly trivial system admin commands everyone else can, then I’m kinda’ pooched, 'eh?

Could it be the directory where those commands are located is missing from the path?

OK, where do I find them, and how do I add them to the “path”?

Sadly, and inexplicably, WD have chosen to split their firmware code base. adding another entire branch, based on BusyBox for the v2 ‘Gen 2’ MyClouds, rather than Debian used by the earlier v3 and v4 firmware in the ‘Gen 1’ models.

This gives everyone headaches:

  • WD have to maintain another entire firmware branch, with supporting documentation and Support
  • Users are confused by what product they have, and how to make it work properly
  • Forum members find it hard to give advice, because there’s a whole new environment that they would have to learn.

I think they’re utterly bonkers, and if I was their product line manager, I would never have allowed it. I would have insisted on a common platform for the entire MyCloud range, with a common code base, and additional modules added to the higher spec models. This would have made everything simpler; code maintenance, support, documentation, user experience and forum support.

Granted, the different models have different CPUs, memory, etc. but this isn’t too hard to deal with; it comes down to the board personalisation support.

Google is your friend :slight_smile:
Search for “find” command and path options. And if these boxes have Busybox, well search for that OS.

https://busybox.net/downloads/BusyBox.html

Now, NOT all commands might be there, since this could be a light/custom version of it.

Also from your login output, a big clue:
“BusyBox v1.20.2 (2015-02-25 14:32:43 CST) built-in shell (ash)
Enter ‘help’ for a list of built-in commands.”

help…

ADDED:
At this point, you might have better luck asking on a Busybox forum than here…

Cpt,

When you’re right, you’re absolutely right!

[rant]
I, myself, have been involved in software QA for, oh, well, ah, longer than I’d like to admit! and it just boggles my mind.

If we grant the possibility that different processor families will bend the code in particular directions. . . And if we grant the additional possibility that porting from processor “A” to processor “B” is a non-trivial task. . .

In any event - especially in the Linux world - maintaining even a “reasonably consistent” code base should not be hugely difficult. Especially when you compare it to the headaches and issues raised when you fork the code base like this. With a little care, you can run Linux distributions that are - at the very least - functionally compatible on everything from CERN’s supercomputers to a Raspberry Pi, to a wet pancake.
[/rant]

Sigh. . . .

So, how do I get from where I am to where I should be?

Jim “JR”

Wise guy!

Give 'em a SMACK!! (laughing!)

1 Like

Well you could run an “sudo apt-get update” but be prepared to in all likely hood brick the My Cloud. :laughing:

One way to find where certain command files are located is to run a search for them either using SSH or via the Find Files in WinSCP.

For example using SSH one can issue the command: find / -name "fdisk" which on the v4.x firmware yields the following:

WDMyCloud:~# find / -name "fdisk"
/sbin/fdisk

:sunglasses:

1 Like

Does anybody know if gen 2 clouds are 4k or 64k code files. If 64k then fdisk from a gen 1 cloud could possibly copied to the gen 2 cloud. Missing libraries could be a problem. Otherwise a standard debian program could be copied to the gen 2 cloud.
In either case running fdisk on the gen 2 would just fail to run if it is the wrong version or is missing a library.

RAC
PS fdisk is not on the gen 2.