Let's all be honest, WD MYCLOUD is hunka junk

I’ve given up. Terrible product. Anytime the solution is go into the internals and shut off services, I’m done. And I only have thousands of photos. I can’t imagine what users do with real volumes. I’ve had this about 6 months and I am done. I’ve tried to make it work. Safepoints, mobile apps, nothing works. It keeps disconnecting from the network so I can’t even use it has a local storage device. It’s going in the trash.

1 Like

Well, I’d sell it, or open it up, and extract the SATA HDD, and use it either internally to a PC, or use a USB to SATA adaptor.

The WD red drive it contains is very good, even if the NAS function isn’t so good.

That’s your prerogative as for me I have had mine two years this month and I am not having any problems. My home network setup has almost every thing fairly new and kept up to date. My router is a Linksys 1900ac (802.11ac). My desktop and laptop (laptop is just three months old) computers both run Windows 10 and both have 802.11ac wifi. I also have a Linksys AC1200 Max Wi-Fi range extender.

My internet service is with Time Warner Cable. I own my own Modem and it is not that old.

My suggestion, take a look at your overall network and see what you may be able to do to improve it.


1 Like

Just kill all WD stuff inside (wdphotomerged and one more service… Search at forums)
Or you can install clean OS (Debian wheezy and jessie available now. Also we can install DSM and OMV. Look my threads/posts)

1 Like

Well everyone has their own opinions. But if one is being TRUELY honest they’d realize that while some have problems with the My Cloud, there are others (possibly even most others) for whom the My Cloud works perfectly fine for their needs. One cannot base how bad a product is simply upon the issues posted to the support forums. WD has, I’m sure sold tens of thousands of My Cloud devices, the people posting here represent a fraction of those users. Generally people don’t come to a support forum unless they have a problem.

Perhaps, GELANG. if you would post your specific problems you might get a user who can help you resolve what ever your specific problem. Yes the My Cloud has its quirks, very specific behaviors, problems (some induced by WD themselves by removing remote drive mapping or not supporting Windows Phone), and its limitations (like granular control over shares/folders and poor Twonky integration), but not all issues are the cause of the My Cloud. There are workarounds or solutions for many of the issues people experience. As we’ve seen Windows 10 and Mac’s El Capitan themselves cause some problems that some choose to blame on the My Cloud.

A fair number of the complains about the My Cloud stem from people not reading the entire My Cloud User Manual, failure to setup the device properly, or who have unrealistic (sometimes wildly unrealistic) expectations of what the device can do, or should do. And there are one or two who simply don’t understand what they purchased and complain about how the drive isn’t like an external USB drive.

Speaking for myself the My Cloud works fine both locally and remotely. I have only one problem with the My Cloud, it doesn’t recognize two of the several external USB drives I have. For the price and the features (as limited as they are) the My Cloud is actually a very good deal. Typically the price for a My Cloud runs $10 or $20 more than the WD Red drive contained within it. So for that $10 or $20 your getting an NAS + media server + remote access, versus just a basic hard drive.



I want to build a bit on what Bennor said in his very thoughtful piece.

First, read the manual. I can’t stress that enough. Unlike a copy-cat smart phone, you can’t just hit the power button and expect everything will make sense. The WDMyCloud is far more complex and requires several well though out steps to set it up. Success will come only when you fully understand what you are dealing with. This is not an external hard drive and if you treat like it is you will end up with a useless brick. It requires careful attention to detail when creating the users and shares.

Read the manual, then read it again! Write down your planned user(s), and skip adding passwords until you have successfully created the accounts and shares. Load ONLY some sample test data – not your whole 20 years of pictures or 10,000 MP3’s. Play with it. Get used to connecting to the device and extracting sample data. Pull up the Dashboard. Play with it. When you are completely comfortable with its operation, then load it up and then add your passwords. Then back it up because no matter how many copies you have you never have enough.

My WDMyCloud works almost flawlessly except for issues brought directly into the game by Windows 10. I can’t undo or fix the Windows 10 issues but I can (and you can) work around them to get the most out of the WDMyCloud. There are several threads here about dealing with Windows 10.

And, when things don’t seem quite right, drop in here and ask for help. There are a lot of very helpful people here.


My Configuration (for those interested in a sample setup)

WDMyCloud 2TB – three USER accounts, passwords for the private accounts. The WDMyCloud is set for DHCP (but with a permanent IP assigned by one of my routers), Sleep=Off, Auto Update=Off, Remote Access=On, USB Availability=Yes, SSH and FTP = Off, Media Streaming = On, Safepoints = On (external drive connected) and three shares in addition to Public. I have only about 600 GB loaded.

My network is mostly Gigabit with 5 routers (one is a bridge), 2 physical locations bridged with a 2.4 GHz link, 2 independent high speed internet connections and a few computers, tablets, TV’s, Blue-Ray players, iPods etc. etc. I am able to stream videos to any point in the LAN using the Twonky server in the WDMyCloud and/or using the Serviio server in my computers.

The WDMyCloud, in my environment, works as advertised.

+1 as @Morden2004 said.

There are two things I recommend and have mentioned in the past on these forums:

  • Before moving all your data, get to know it. Read manual, familiarize with the terminology/commands/etc. Do a trial playing with user/share creation. Once you comfortable, reset to default and do your final config.
  • a NAS is not a USB drive!!! Most people have lots of issue cause they “believe” or keep the same mentally as if this was a USB drive.
1 Like

Ditto to much of the above. I do not have the basic My Cloud, I have the stepped up DL2100 NAS. It seems not to have the issues that plague the basic My Cloud, and I would think the older My Clouds have the issues, where as the newer ones do not today.

Ever since I got a WDTV years ago, I had to learn and figure out how to create a properly working home network. It took lots of reading, proper set up, and purchase of new equipment to get gigabit speeds, dual-band N, etc.

I know I have it all set up correctly today, because over 30 devices are connected to the network and they all work!

So, it all starts with a working home network, so when I set up my DL2100 a few months ago on network, it just worked.

I still do not have passwords setup to use it, since no one can get into it outside our router password access. Anyway, it contains only media files for home access (and remote via My Cloud app).I have gradually been adding my complete sets of content. Just last week I transferred all photos and videos to NAS from my iThings using the My Cloud app, and it worked flawlessly.

I have also helped many friends set up routers, gadgets etc. Most are clueless about computer gadgetry. Even if they know “something” about this, they are still basically clueless.about it.

Just this past week, a friend I have helped a lot, told me his wife’s micro SD card for her phone got corrupted and she lost all photos and videos on it. I said, well, it was backed up wasn’t it? The answer was no.
I rest my case.


Thanks for your post.
I have been able to use two MyClouds locally and remotely. Bennor needs to spell TRULY correctly (not TRUELY) :slightly_smiling: I am using Windows7 on my two PCs and my only Mac has Snow Leopard.
I have been having two problems on my Win7 box: 1) the WD App Manager consistently crashes at start-up; I can’t remove it via Control Panel;
2) the backup from MyCloud to the USB drive attached to it fails consistently; yes, the drive has enough space.
I am able to access the MyCloud drives from my Mac locally.

So … has anyone had a problems with WD App Manager, and scheduled backups?

I will keep searching for a while tonight, as I seem to be get 50 or so hits using “stopped working”. Unless I am having a senior moment, not one of them is specific to WD App Manager.

I have a Netgear Nighthawk, new cables, configured direct to router. I stand by my statement that this is a hunka junk. As for all you rocket scientists out there, if that’s what it takes to get this product working then WD shouldn’t market this as a home NAS. They should market it for all you computer geeks and nerds.

[quote=“Bill1234, post:9, topic:146097, full:true”]
Bennor needs to spell TRULY correctly (not TRUELY) :slightly_smiling:[/quote]
Hey don’t blame me blame the stupid browser spell check not catching the incoroectly used word. :grin:

To echo what others have said which cannot be repeated enough. RTFM!!!

WD My Cloud User Manual

When having problems with the WD software, the first step is to uninstall it then reinstall it. If it fails to uninstall then try to install the software again over the top of the existing software and test again.

Some have reported problems with the SafePoint backup not working properly with the latest firmware versions. For some it works, for others it doesn’t. Best suggestion is to open a Support Case with WD and send them the logs from the My Cloud. The more data points WD has the easier it will be for them to track down and fix that problem in the firmware.

1 Like

My 3TB MyCloud took a dump after 5 years. I was going to back it up with a new drive, hind sight is 20/20. I lost so much data… Music and Movies. I believe that if you buy a drive make sure its just there for backing up data and then unplug it for the next time. I’ll never buy another MyCloud with a crappy RED HD.

Hard drives of all brands and types can and do fail. The single bay/single drive My Cloud units include the ability to back themselves up to a USB hard drive so a user doesn’t loose their data. It is up to the user to attach a USB hard drive to the My Cloud’s USB port and enable that Safepoint/Backup option in the My Cloud Dashboard.

If one’s My Cloud hard drive has failed they can remove/extract that hard drive from the My Cloud enclosure and use a new hard drive in its place after performing one of the various “unbrick” procedures on the new drive. Plenty of past discussions on replacing the My Cloud hard drive with a new (larger or smaller) hard drive and running the “unbrick” procedure on it that can be found using the forum search feature, magnifying glass icon upper right.

when you right click to create a new folder and have to wate 3 mins you know its bad