LED question .... LED stays OFF

tried searching … most threads about this are 2016 & older …

i have a my cloud that’s got 4.x.x.xxx firmware.

noticed about a month or so ago … the led does not glow blue. the setting is ON in the dashboard.
a few times this drive became unresponsive to the point where i had to physically unplug it and plug it back in (recently, 2 times in the past week).

when it powers on i get a solid white (or yellow ?), then after it’s booted and running … no LED color, it is off.

while i’m brining this up … worth noting that i also (in the last week) decided to give the AUTO-UPDATE feature of Safepoint another try. tried scheduling for an overnight backup.

the next day i woke to some 16 emails from the NAS telling me the attempt to backup failed (code 1102).

anyone with insights please ? could i expect this drive to give up soon ? if so, may be time for a change to another NAS model.

Blue LED failure is a common problem; WD obviously designed the LED drive badly, or bought very poor blue LEDs. Mine failed years ago, but the drive works fine.

Just for kicks, I changed it to green recently:

very good suggestion. actually more visible and better looking in green …

thank you very much for the tip !