Laptop acknowledges the element but cannot access it. device not ready

ok so i bought the 1tb element from a kid, got home worked great for 2 days. then it wasnt being seen by my laptop. ive been all around and upside down getting it back to being seen but i still get device not ready, wdutilities doesnt see it at all. did i not close it out correctly before detaching it. i fallowed everything. is a file left open possibly the culprit? im determined to see this through. ive gone through everything and am still locked out?

1 Like

Hi @ROBERTRRII,

In order to troubleshoot your issue, please provide the following information:

  1. What Operating System are you using? Please include the version.
  2. Have you tried to plug the drive into a different USB port?
  3. Have you tried to connect the drive using a different USB cable?
  4. Have you tried to connect the drive to another computer?
  5. Have you done any other troubleshooting on the device?
  6. Do you see any error messages when you connect the drive to the computer?
  7. Is your drive visible in the Disk Management or Disk Utility?

Please refer to the following articles for accessing the Disk Management in Windows and Disk Utility on macOS:

Title: How to access Disk Management in Windows
Link: How to access Disk Management in Windows

Title: How to access Disk Utility on macOS
Link: How to access Disk Utility on macOS

Please refer to the below link to troubleshoot the issue:

Title: Windows or macOS Cannot Find My Drive
Link: Windows or macOS Cannot Find My Drive

Please test the health of your drive using the Western Digital Drive utility:

Title: Setting up and using WD Drive Utilities
Link: Setting up and using WD Security and WD Drive Utilities

Windows 10 home
I went around 15 rounds with that disk and ce out victorious. Got rid of the RAW repartitoned the disk and have access and use of it sgain. Hours of trial and error i went in management and 0 valued the write protection at that point i went back out to desk top and run it through 2 program to clean up any mess on the drive. I spent evety bit of 15 hours reading trying a suggestion then back to start. There are a couple of good programs out there that help alot. Same as sites suggesting how to approach the issue and what todo once at it. Ive been teaching myself about computers over the last couple yrs. Frustrating but fun.

Hi,

I appreciate that you have performed the troubleshooting steps.

Please contact the WD Technical Support team for best assistance and troubleshooting:
https://support-en.wd.com/app/ask

‘The device is not ready’ error occurs due to reasons such as:

• External storage device already in use;
• There are malware attacks;
• There’s a serious hardware failure due to corrupt USB controller drivers.

Due to this error, you will not be able to access your drive. However, you can try the below troubleshooting methods to fix the issue:

• Run Hardware & Device Troubleshooter
• Uninstall USB Controller Drivers
• Run CHKDSK Command
• Fix USB Root Hub
• Update Device Drivers
• Change/Assign Drive Letter

Further, you can also check the below link for more detailed methods:

Hope it helps!

it shows up and has been wiped clean. now i need to reinstall the software and driver. it went back to raw and the program i used took everything out,

ive learned so much more about my laptop in the last couple days its amazing. i really had no idea of whats all in this thing but the subfolders in the folders in the progtrams hell it p rabbit hole. learned the hard way to close the doors you open on your way back out hahaha; im now looking for software and image and driverr reinstall download. thats where i have chased this to, twice. shes a black spinning chunk right now, nothing inside to work off fo