JBOD on My Cloud EX2

Just put two 2TB Seagate Constellation ES drives into my diskless My Cloud EX2. I selected JBOD (no spanning of the drives), and began the setup. The EX2 now shows 4TB of total storage. If I go to the setup menu, it shows 2 drives but in windows/network explorer, it appears as a single drive (with single Public, Time Machine and SmartWare folders). It sounds like it is spanning the two drives but that’s not what I selected on setup (and I repeated the process a second time with the same results).

Is it spanning the two drives? What’s going on here?

Thanks in advance.

“Anybody… Bueller… Anybody…???”

What does the unit’s RAID manager indicate irrespective of usable space?

Well, under the Dashboard Storage menu option, Raid, Rail volume, it says mode is JBOD for both drives. but under windows explorer, it shows only a single location for the shares (not one for each drive). Other than under Raid Volume, there is no indication that the setup is JBOD - looks more like spanning.

Normally it will just show your device at the top level, and the shares beneath that (regardless of which drive they are on). You won’t see the actual drives themselves directly.

OK, that’s a little confusing. I could understand that if the box was spanning but with 2 separate JBOD drive setup, how do I know what is on which drive if one goes bad (which, for me, was the main reason for not using spanning)?

When you set the share up you should have the option of which drive you put the share on. And if you look at the share properties the dashboard you can also see which of the drives it’s on.


Thanks. I didn’t set the share up - its the default share (“Public”) that is set up initially by the firmware. It can not be deleted and therefore can not be removed and re-set up on a given drive.

OK. By default that will be on volume (drive) 1.

When you set up your own shares, you can select which of the volumes you create them on.

Ah, OK. So if I don’t do anything now, will the public folder fill up the entire capacity of drive 1 (2TB) and then just give me an “disk full” error and not use drive 2 (2TB)?


By definition the drives are entirely independent - they will fill up individually depending on which shares you put your files into, and on which drive each share is located.

This is presuming you don’t use quotas to limit the size of shares, but you have the general concept now I think.

OK, thanks. I guess I’ll just play with it some a try to figure out how exactly the the NAS does its thing in JBOD mode.

I have switched to JBOD and Public folder is on volume 2. And I can’t see volume 1 in windows explorer or in the web interface. If I go on Storage > Disk Status, I see two disks, but can’t access one of the two - volume 1.

Please help. Thanks.

Create a new share and put it on volume 1. The drive may not appear if there are no shares on it.

No that is not a problem. When I could see it, I had copied data on it. When I create a new share, I am not getting a choice on which volume to put on.

That sounds like one for WD tech support. It doesn’t sound right - you should get the choice in JBOD mode.