iTunes server not working


I have a MyCloud connected to my mac over wifi. I can see the disk in finder and everything works otherwise, but the iTunes sharing doesn’t.

I can see the shared library in iTunes. First time I tried with half a library, I was able to connect and it worked fine. After that I moved rest of my music over and now it only says “Loading WdMyCloud” and then takes me back to the local library. Sharing a library from another mac works fine.

What I’ve tried:

  • Switch DLNA on and off just in case that makes a difference

  • Turned iTunes server on and off (iTunes share set to public)

  • Rebooted the MyCloud

  • Updated the firmware

  • Rescanned iTunes & DLNA in the dashboard

  • Tried changing iTunes library location to point to the MyCloud from preferences

  • Waited couple of days in case the volume was still processing the files

iTunes support was one of the main reasons I bought this device for so I’m pretty frustrated with this. I’m out of ideas what to try next. Could someone help me with this?

Welcome to the Community.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country

After switching the iTunes server on and off a couple of more times from the dashboard I can now connect. iTunes stays in the MyCloud library, but I see no music. Music playlist says zero items. I guess I’ll try running the iTunes scan again to see if it helps.

If not I’ll contact the support.

Just updating this issue. After the latest update I couldn’t connect to the library again for a long time. After that I’ve been able to see the library only once and even then trying to play a song crashed iTunes. Most of the times it comes back to the local library after a second of trying to load the mycloud library.

I tried Plex, but for some reason it couldn’t see all the shares. The one it did see wasn’t even set to public or media serving. After the first time it doesn’t even see that anymore. Like the drive wasn’t there even if finder is connected to the drive just fine. 

Going offtopic, everytime I’ve really needed this drive from the outside is says the device is offline. I come home and surprise it’s online and everything is ok. I’ve used this from the outside a couple of times so it’s not an issue with settings.

Everything is so random with this device. If you reboot and reboot and hope for the best it just might work and connect for a while and then boom it’s gone. Can’t really trust it. The mobile apps are just bad. Uploading pictures and they get stuck and the app freezes.

Really dissapointed in this expensive brick that’s blinking in the corner. Should’ve gone with Synology or something.