iTunes Problem

Why is it that the WD MY Cloud shows up under the iTunes Shared Library tab, but when I click on it, iTunes won’t connect to the My Cloud drive?


Take a look at this link, hope it helps.

iTunes server and how it works on a WD Network drive

Both of these are turned on under the Media Settings of the Dashboard. Turning them both off and back on again really doesn’t do anything to help fix this problem.

So I got iTunes to connect to my WD My Cloud, but it only shows a couple of songs rather than the 18k that are on my external hard drive. Any ideas? iTunes is on in the Dashboard and when I hit Rescan, that does nothing it seems.

So the songs are on an external disk attached to the NAS? That could be the bug/issue, according to other posts reporting weird behavior with shares corresponding to attached USB disks.

Correct. All of my music is on my WD My Cloud. When I load iTunes, I click the little icon in the top left corner and change it to WDMyCloud and when once it loads and connects, iTunes only loads a handful of songs rather than my 18,000 song library. Not sure why.

I am not sure you are confirming whether the files are on the NAS or on a USB disk attached to the NAS. If on the USB disk, does the problem subsists when you move files to the main disk?

My iTunes link to the drive disappeared between two of the recent MyCloud firmware updates but the very last brought it back and I can now see of of the files. Well I’m guessing this was the case although perhaps it was the reboot that caused then to reappear.

For info, I don’t use itunes/itunes library to rip/organise my music files - I just rip them straight to the MyCloud through dBpoweramp. 

The files are on the NAS. It was working perfectly fine before the latest update.

I am running out of ideas. You did the basic troubleshooting of rescanning. If you have the very latest firmware, the iTunes problem should be solved.

Did you try to simply reboot the system, turn off the media scanning for the shares, and turning them back on. I have to believe this is a media database issue…

Yes. I did all of that. I have no idea what to do next.

Just a couple of others ideas although they are obvious so guess you may have tried these…

After a reboot do a rescan of your itune database from the dashboard

Check your settings in the Twonky server as these seem to revert to the default at each firmware update - I’ve even had these revert on a reboot. I’m not sure this impacts on the iTunes server but worth a check

What is the Twonky server?

It’s the server built into MyCloud for sharing music. You can access the settings page by entering your MyCloud ip address followed by :9000 into a web browser e.g. More info can be found here,-ex2,-ex4,-my-book-live,

As I mentioned before this may not have any impact on seeing files in iTunes but I’m sure there’s a more knowledgeable poster on here who can confirm. 

Under Settings - Media - iTunes Server is on.

I go to the Twonky Server and it scans all of my files the way that it should, but it says Not Sharing.

I click the little icon in iTunes on the top left corner and change it to WDMyCloud.

iTunes says loading WDMyCloud, but then doesn’t connnect and returns to the startup page.

Any thoughts or suggestions?

Content Scan is Idle. I have the latest firmware with a green check next to it… Diagnosis says Ok with a green check. DLNA Server is also ON.