Issues with PLEX and My Cloud Home

Looking at the number of less-than-positive posts on this forum I’m not sure I’ll get a solution to this but here goes.

I got a WD My Cloud Home with the intention of having an easy to access network drive to store some of my big files and media and stuff on to free up some space on my laptop, thinking it would be convenient to be able to just plug it into my router and access it over the WiFi, as I have a good WiFi network here. Wow do I wish I’d researched this further before buying it. It turns out this thing goes out of it’s way to make things difficult and restrict how you can use it. Anyway that aside…

Main issue I’m currently having is with setting up a PLEX server. I’ve enabled the service and the PLEX folders have appeared on the drive. I’m mainly using this to run my music library. However there seems to be a lot of issues with how this is working.

Firstly, PLEX is struggling to read the metadata from my files. I have all of my tracks tagged correctly and with embedded album art, that seems to be perfectly readable in other applications such as MediaMonkey. However PLEX just gives me a bunch of lovely blank coverless albums. (Yes I’ve tried messing with the metadata agents and all that).

That’s ok though I thought, I can go to the edit metadata button and the album art is actually there under ‘posters’, it just hasn’t been enabled. So I can manually set it up. Quite time consuming though as I have a big collection of music.

Ok, so I tried this on a (fortunately small) subset of my music and had it set up on PLEX with correct metadata. However it turns out that if for any reason the My Cloud Home device is restarted, all the metadata in PLEX gets reset? So there goes all my album art again, as well as any changes I’d made to the other artist backgrounds and posters and some organisational fixes. Surely this can’t be intended behaviour? Where are all my edits going?

Is there a solution for any of this? Ideally I don’t want to manually have to set up all my album art on PLEX anyway, but I’m certainly not going to do it for thousands of albums if there’s a risk all of it’s just going to be erased if there’s a power cut and the My Cloud Home restarts and removes all my hard work. So if there’s no fix for that then PLEX is out the window.

I’ve had this thing for a week and I feel like I’m banging my head off a wall now. Honestly, if I hadn’t already unsealed the packaging and used the thing for a few days I’d be returning this, unfortunately that’s not an option now so I’m stuck trying to salvage some kind of usefulness out of this thing. Hopefully someone can give me some good news or maybe some suggestions of ways to actually get some kind of benefit from this device…

1 Like

@Psychometric I will have someone from support contact you

I did a bit more testing with this, monitoring what the PLEX web app does when the My Cloud Home is restarted. The media on the server appears offline while the device is off, understandably. When the device is powered back on, PLEX then systematically deletes EVERYTHING from all of the libraries - it actually shows this in the PLEX activity log as just sequentially deleting every library item. The folders then rescan automatically and the library contents are added again as they were the first time, of course that means all the library metadata is back to whatever it was before I corrected anything.

This is obviously completely useless, I can’t be having to completely reset my whole library if the device ever happens to be restarted. I tried turning off any settings on PLEX along the lines of ‘update my library automatically’ etc, but even then the same thing happens.

Not impressed with this device at all. Retailers won’t normally take returns on things like this once they’ve been unboxed but given how bad this is I might try anyway on the grounds that this device is not fit for purpose.

2 Likes

also noticed this weird bug where plex will delete all my movies and rescan again just to add them all back

so wd need sort out whats going on with the plex data folder as its obviously wiping itself or setup to wipe and rescan if you reboot the cloud home

pretty terrible product… wonder if does the same for the duo model

1 Like

Same bad experience. IF YOU ARE PLANNING TO BUY THIS PRODUCT AS A PLEX SERVER, DON’T BUY!!!

2 Likes

I´m also having the same experience and now PLEX struggles to play any of my media at all.

Please help!!!

I have given up on using Plex on WD My Cloud Home for Serving Music as it does not import the metadata and I have since went to Amazon Music Unlimited through Alexa enabled devices through my house.

I have both WD My Cloud Home and WD My Cloud EX2 Ultra devices.

I use WD My Cloud Home as a Plex Server for Videos and find it to be excellent. I could not be happier with organization of movies and tv series and the way it performs with my LG Smart TVs.

I use the WD My Cloud EX2 Ultra as my NAS and iTunes Server and also find it to be excellent.

Would I prefer a single device that does it all? Probably, but I am very happy with these WD My Cloud products knowing what they do and don’t well.

Has anyone found a solution to this? This is happening to me to! I live in Texas and we have storms all the time that knock out the power and then great I have to go fix my movies again… Deletes all the movies I have previously fixed with correct metadata… I don’t mind fixing it once but fixing it every time we have a random storm or power surge isn’t going to cut it…

1 Like

Any update regarding this issue , as I have a plex server through my WD cloud homeand every time the cloud is restarted all my saving metadata and collections are reset!

Hi. Has a solution been found for this as i am having the same issues!

Plex 1.16.3 has been released for My Cloud Home and Duo.

  • Rebooting the My Cloud Home will trigger the update which should take a few minutes to complete.
  • Delete and create a new library if you experience any artwork or metadata issues when upgrading from 1.12 to 1.16

yeah, the day has arrived, 1 year and 2 months later WD update Plex, finally, let’s see if they update it sooner. And the most incredible thing is that the My Cloud Home version is 16.3 and the latest of Windows is 16.2, interesting

1 Like

Good to see there’s been an update, will try it out later and see if it resolves any issues.

Hi everybody, so, when I Updated to last version of Plex in Server My cloud Home 1.16, I can´t see my files with Remote Access, If i´m in Local network it works fine, but not outside of my network.

I tried port forwarding in my router but it didn´t work.
The main status of my cloud home is “Direct”, but Plex still with the issue.

Anyone has the same issue?

4 Likes

I’m having the same issue as well. It’s so irritating and I’m also having a problem with connecting securely. Plex keeps telling me that it can’t connect securely. Ugh… I really hope WD can help me resolve this. I haven’t rebooted my My Cloud Home because I don’t want all the metadata to be deleted all over again. It seriously takes 2 hours to put everything how I want it. Movie posters, Collections, etc. Help!

I too have lost all my metadata AGAIN due to the update and restart. Are WD telling us that this most recent update will resolve the issue? If not, can they make the database files available for us to back up like it would be the case on any other Plex Server?
Hoping this is the last time I have to go through and re-do the all the posters etc. I’ve only had the device 4 months and this is about the 12th time. Getting ridiculous now.

Yes same Remote Access issues here too!

Mines working fine, from memory, it didn’t originally and I had to go into plex ‘settings’ and set port manually under ‘remote access’ the typical/set port just didn’t work for me…

Having tested this it appears to have resolved my main issues. Album art is now displaying as it should from the file metadata without having to be manually selected.

Restarting the My Cloud Home no longer results in the library contents being deleted and re-scanned - all my PLEX metadata adjustments remained in place after a restart.

I’d still ideally like more control over the server itself (plugins, etc) but this update has been a positive one - if any new issues appear I will post with an update, but for now this has resolved the main issues for me. Thank you.

1 Like

sigh May have spoke too soon.

Everything seemed to be working fine, library contents were remaining in place after rebooting the device, remote access was working, all seemed fine.

Wend to bed and woke up to find my PLEX library contents have mysteriously deleted themselves and the library is once again empty.

Having to rescan everything again, this is the last shot I’m giving this, it takes hours to rescan this stuff despite me only testing this with a small fraction of my music library at the moment. I’ll see how it goes but if I continue having problems I’m going to find an alternative device that actually works I can’t keep wasting my time with this.