Is the Live Plus ever getting a firmware update?


#1

Im past my 30 day return and i assumed we would get some kind of updates. Ive already seen the regular Live get a couple beta updates but nothing for live plus owners. Throw us a freaken bone here. 


#2

Here’s my guess.   

First, the Plus and the Live are based on the same “core” components, and are forks of the same 1.03.x firmware.

The 1.03x firmware included a new release of Sigma’s SDK core, which introduced a lot of HDMI issues that WD wasn’t able to reproduce in their labs, or affected what they thought was a very small percentage of users.

As a result of having the same core, It appears as though both the Live+ and the Live Betas are having the same issues, so WD is attempting to correct them in the “Beta” code before issuing a “Public” release.

Since the Live+ was introduced, there have been three Beta releases for the live, and while the HDMI situation is improving, it has not been resolved for a large base of users.

I’m guessing a lot of this “Waiting” is on Sigma to fix their code.  Apparently, this HDMI issue is a tricky one for them to track down…

The Live+ also adds Netflix, which has its own list of fairly annoying bugs that WD reported they were still trying to fix.

I would wager that both the Live “Public” release and the Live+'s first upgrade will be within a few days of each other.


#3

I have dibs on Christmas! :slight_smile:


#4

I hope it’s not that long.

I have owned this box for about two months now, and have never been able to use Live365 as a VIP member. Support confirmed the problem and said it would be fixed in the next firmware update. In addition to a few other problems that have popped up, this box is still in “beta” mode.

I owned the “Live” unit for about a week before the Plus came out. It worked perfectly, including the Live365 feature. Seeing that the Plus was the same box, with Netflex added, I returned the Live and exchanged it for the Plus. It was a lot different experience as it seemed like a much different product. One that was not quite as smooth operating as the Live. Even the Netflex part needed to be reset twice as I was getting the “cannot connect to your Queue” error.

I don’t regret my purchase as Network Shares works fairly smooth, and Netflex works after the two time reset. I just hope they smooth out the rough edges pretty soon.


#5

Jackster wrote:
I have dibs on Christmas! :slight_smile:

Hmmm – I’ll take the “under” on that one (now, if someone wants to take Halloween I might take the over).


#6

JohninLA wrote:

I hope it’s not that long.

 

I have owned this box for about two months now, and have never been able to use Live365 as a VIP member. Support confirmed the problem and said it would be fixed in the next firmware update. In addition to a few other problems that have popped up, this box is still in “beta” mode.

 

I owned the “Live” unit for about a week before the Plus came out. It worked perfectly, including the Live365 feature. Seeing that the Plus was the same box, with Netflex added, I returned the Live and exchanged it for the Plus. It was a lot different experience as it seemed like a much different product. One that was not quite as smooth operating as the Live. Even the Netflex part needed to be reset twice as I was getting the “cannot connect to your Queue” error.

 

I don’t regret my purchase as Network Shares works fairly smooth, and Netflex works after the two time reset. I just hope they smooth out the rough edges pretty soon.

So what problem do you have with live365? What exactly did ‘support’ confirm because as far as I am aware nobody has had any problem on this forum with live365.


#7

 I am just curious why some of the stuff in the Ideas Lab has been under review or consideration for over a year, and not implemented. Do you guys have like one High School Nerd working on your firmware in their study lab of something? Hire b.Rad, [deleted], or release the firmware as open source code …


#8

Hi Rich, here’s the link to my original post about this:

http://community.wdc.com/t5/General-Discussions/WD-TV-Live-Plus-and-Live365/m-p/28150/

highlight/true#M8368

You had responded to that post and confirmed that you were also having problems with the firmware. I still can’t access my Presets on the Live Plus.

Thanks.


#9

JohninLA wrote:

Hi Rich, here’s the link to my original post about this:

 

http://community.wdc.com/t5/General-Discussions/WD-TV-Live-Plus-and-Live365/m-p/28150/

highlight/true#M8368

 

You had responded to that post and confirmed that you were also having problems with the firmware. I still can’t access my Presets on the Live Plus.

 

Thanks.

Gosh how time flies. Sorry I forgot all about that!!!

I have updated to the latest beta firmware on the live and I can tell you that Live365 is now OK. I can access recommendations and my presets. As the firmware for the Live and Live plus share a common base this means that the next update for the live plus should solve your problems. (fingers crossed)


#10

Thanks very much. I’ve been patiently waiting, so hopefully it won’t be too long. Take care.


#11

Up to now, newest fw version is   1.03.29_B   , isn’t it? Obviously i’m talking about Live Plus


#12

Yep; that’s the first (and only) version thus far.

By the way, I’ll take the UNDER on both predictions made so far…


#13

No fair – the FCC would fine you heavily (for “insider” trading).


#14

smrdelj wrote:

Up to now, newest fw version is   1.03.29_B   , isn’t it? Obviously i’m talking about Live Plus

No its 1.03.38_V


#15

V= Villa = WDTV Live B= Bungallow = WDTV Live+