\\...... is not accessible. You might not have permissions to use this network resource

Hello, I have a WD MY Cloud 4TB NAS. For some reason, I cannot access any of the “non public” shares without getting an error on my Windows 10 PC…

“\wdmycloud\username is not accessible. You might not have permissions to use this network resource. Contact the administrator of this server to find out if you have access permissions.”

I can access any of the shares that have public full access, but any of the other folders that are restricted by user permissions, I cannot access.

I have rebooted PC / NAS several times, with the same issue. If I change the shares above to public full access from the Dashboard, I can then access them, but as soon as I change the permissions back, I cannot.

When I type in the ipaddress\foldername , it prompts me for Usename and Password. I enter the “WDMYCLOUD\username” for the Username and the associated password, but I still get the permissions error.

What am I doing wrong? :frowning:

djino

Generally one does not need to enter “WDMYCLOUD\username”, rather just the User name created in the Dashboard and the password assigned to that User. One generally doesn’t need to precede the User name with “wdmycloud”.

I wonder if this is the windows problem with not allowing multiple sets of credentials when accessing network drives.

Certainly if you map shares as windows drives (E:, F: etc), you need to connect them all with a single set of credentials (the MyCloud user and password).

How are you accessing the Public share? Since it doesn’t require credentials, windows will probably connect with your windows user credentials. Thus, trying to connect to other private shares will require you to enter your mycloud credentials, and windows won’t like this mixed set of credentials.

I had this problem when first trying to map shares. The answer was to unmap everything, and then map all shares with the same set of MyCloud user credentials.

I have tried with just the username …same result. :frowning:

Unmap everything as in unmap all shares I have in Windows. Or remove all permissions on the NAS from the dashboard?

Unmap all Windows drives that are associated with shares on the MyCloud.

Then reboot the PC, and re-map the drives, this time, specifying your mycloud user credentials for all drives, including any public shares.

Probably nothing…Had this problem… try resetting Network protocol to SMB1 in the Dashboard.(can revert to 2 afterwards).