WD Share asking for Credentials

Hi there

Odd one here… I have a share folder on my WDCLOUD that i have locked down so that only my admin account can access. Now for some reason it keeps asking me to enter credentials when i try access it? Only way i can access it is to put it down as a public folder?
I notice that it also wants a domain? Ive tried WDMYCLOUD and my local host details.
Even if i enter my admin credentials to connect it tells me its wrong. See images below :

1 Like

Have you tried your Network User Name and Password? The other week I even used my computer/Microsoft User Name and Password. Try both of those and see what happens.

1 Like

The last half of the error message is telling you what the problem is. If you first access any other share NOT using your admin credentials, you can’t then access another share using admin credentials.

It’s a Windows limitation… not a WD limitation.


Solved…Just me trying to over complicate things clearly :stuck_out_tongue:

Hi I have the same problema but I don´t have any other connection? I am clueless of what is going on, and further more I can not acces using MYCLOUD.com both from the local network and from outside

If you’re getting the same error, you DO have other connections.

I think you have. A guest connection. It’s where the computer connects to a public share/resource using credentials that are not defined on the server. I think the WD NAS allows guest connections to public shares.

None of the above helped me, I solved it this way as I wrote here:

Hope helps you.