Is my WDTV dying?

Hi All,

My WDTV still seems to be going great, except for one symptom that I don’t understand.

When I play a movie with .srt subtitles, and the scene is dark, the subtitles will go all fuzzy and hard to read. As soon as the scene lightens, the subtitle gets clear and crisp. It’s only when the scene is dark that this happens, and it only started happening recently.

I have 2 other media players, an Asus and a Shield, and both of those play the same movie and subtitles ok, so probably not a problem with the TV.

I’m thinking the WDTV might be starting to lose some power or something in some component, does that make sense?

Any thoughts from some of the old gurus still hanging around?


Don’t know the answer as i’ve never heard of this … but some questions

Are these .srt subtitles external or embedded ?

If External … try muxing/embedding them into the video container to see if it’s the same. (for mkv use mkvmege, for mp4 use MP4Box)

Does it happen in a movie with hard coded subs ?

Sounds strange doesn’t it? I almost have a feeling it’s the TV, not handling contrast or something in a dark scene, except that the other 2 media players don’t have the same effect. The subs are clear and sharp.

The subs are external .srt.

Movies with hard coded subs have no problem.

I would have to find mkvmerge somewhere and install it, but does that mean then the subs would be hard-coded? In that case, there wouldn’t be a problem.



Embedded .srt subtitles are “Soft-Coded” … meaning they can be turned on or off (or stripped out of the video container entirely)

mkvmerge will embed the .srt without any video or audio re-encoding and the whole process takes around 1 Minute depending on the size of the movie and the speed of your PC.

mkvmerge is found within the mkvtoolnix package.

I prefer the old version as it’s easier to use … go for an old portable version (exe ones are installers) eg. mkvtoolnix-unicode-

double click the file mmg.exe which is the GUI for mkvmerge, When launched, drag your movie file and srt file into the main window and click Start. It wont overwrite your original movie, it will create a second copy with the subtitles embedded.

Thanks a lot… I’ll try it out and let you know

just thought of one other thing … depending on the model of WDTV you own, the later ones had options for Subtitle Color border and fill.

if your WDTV has those settings … i wonder if that will make any difference ?

just wild guesses here :slight_smile:

So I installed the mkvtool and while I was working, I discovered another file which already has the subs embedded, and has the same problem. So looks like not only when the .srt is external.

I tried changing my subs colors and border.

When I changed to a thin border, black subs with white border, the problem is least noticeable, but you can still see the subs getting a brighter intensity during the dark scene.

The worst is when I have yellow or white subs - during the dark scene, they just get so intense that they bloom into almost an unreadable blob.

So looks like the black subs have less problem because the contrast is not so big.


The other file is an .mp4 which has the issue, so I got MyMP4Box and tried to demux. I thought I’d try to remux again.

Not having any luck, not sure what’s supposed to happen., but I click Demux and don’t see any output, nothing seems to happen. It just flashes “processing” for a second, and then nothing.
Nothing in the log either.

Any idea on what’s going on?


did you tick the boxes next to the video and audio stream ?

if you don’t, then clicking the demux button will do nothing.


Yes I did check them. I would expect the output to go into the same folder as where the source is, but nothing there. And nowhere you can specify where you want the output. And the processing happens too fast to actually be doing anything, barely a second.

I have the same version, 6.0.6.

Also, I tried examining the files which are behaving oddly, but I don’t see anything unusual - no high bitrate, nothing.

Thanks for any advice, I know this is off topic now.

Edit: ok, I tried another .mp4 and it demuxed ok, so I guess there’s something wrong with the first one.

I’ll try to find another file that has embedded subs and try to re-mux.
Starting to give up now, and thinking of trying different settings on the tv.
Still don’t understand why the other media players don’t have the same issue.

Thanks for all your help.