No subtitles from srt external file on WD TV Live Plus

I’ve owned a WD TV Live Plus for a number of years, and have never been able to get subtitles/captions to display (the menu always indicates there are none). I read
wd-tv-live-subtitle-issues/3254, but didn’t find a solution. Thanks, in advance, for any advice.

I’m currently attempting to play an mp4 file with external captions. The user’s manual indicates on page 47:

Selecting Subtitles … Use this option to view subtitles during video playback. Make sure the subtitle files are located in the same folder as the current video, and that it has the same filename as the video file.
Note: Subtitle files (specific types that are supported) need to have the exact same file name as the media they are playing (the extensions will be different) and need to be located in the same folder as the video file.

and on page 143:

MediaInfo supports the following formats … Subtitles - SRT …

I realize that’s not quite the same as specifying that the unit will decode SRT files, but just to be sure, I tried it with all the files in the same (top-level) directory: fille_du_regiment.mp4, which plays video and audio perfectly; fille_du_regiment.srt, which is a subrip text subtitle file; and fille_du_regiment.vtt, which is a webvtt file (see mediainfo results below). Both subtitle files are English language. The webvtt file is shows subtitles when played on an HTML5 player; the srt file is converted from the webvtt using …

ffmpeg -i fille_du_regiment.vtt -c:s subrip fille_du_regiment.srt

… and appears to be good by inspection.

Even with two different types of subtitle info, the box still indicates no subtitles available. Any ideas how to proceed?

ls -l file_du_regiment.*
-rwxrwxrwx 1 root root 3866478371 Mar 20 20:53 fille_du_regiment.mp4
-rwxrwxrwx 1 root root 60349 Mar 20 23:12 fille_du_regiment.srt
-rwxrwxrwx 1 root root 54427 Mar 20 20:53 fille_du_regiment.vtt

mediainfo fille_du_regiment.vtt

Text
Format : WebVTT

mediainfo fille_du_regiment.srt

Text
Format : SubRip

The About screen shows:

Firmware version: 1.06.42_B
Part number: WDBABX0000NBK

Completely remove and delete any reference to *.vtt files … it’s probably confusing the poor old WDTV.

WDTV Media Players have never supported .vtt and never will and it’s presence is most probably causing your problem.

Test again … with just a mp4 file and a srt (a srt file is just a Plain Text file with no special encoding or characters … WDTV’s don’t even support Unicode UTF-8 in srt’s)

If it still doesn’t work … then embed the srt file in the mp4 container.

an example of plain text srt file (with no special encoding) that the WDTV will display …

1
00:07:47,681 --> 00:07:49,069
Hello.

2
00:07:50,643 --> 00:07:52,612
Hello to you

3
00:10:59,906 --> 00:11:01,226
It’s a nice day

4
00:15:39,316 --> 00:15:42,330
Yes, it is

5
00:16:49,523 --> 00:16:51,287
Goodbye

1 Like

Thanks, JoeySmyth! That was the issue: file_du_regiment.vtt was still there from my first, unsuccessful try. The firmware must have given up on subtitles when it didn’t recognize the webtvtt captions, instead of going on to read the srt file.

The chrome html5 player works the other way around: won’t recognize srt, but is fine with webvtt.