WD TV Live does not recognize external subtitles over DLNA

Hello everyone,

I am having a problem with external subtitle files when streaming movies to my WD TV Live from my computer. I’m not sure where the problem is exactly, but WD TV Live does not recognize any subtitle files associated with video files, even though both video and subtitle files are in the same folder and have the same name.

I am using Mediamonkey as a media server, and my WD TV Live firmware is 2.01.86.

I have also tried muxing an .srt file into the mp4 container but WD TV Live still did not recognize any subtitles for the movie.

All i get is the “Subtitle: Off” indication when the video begins, and when i click the Subtitle button on the remote nothing happens.

Does anyone know what the problem may be? Does WD TV Live support external subtitle files over DLNA? my problem is with both .srt and .sub/.idx subtitles and both .avi and .mp4 video files.

Thank in advance.

WDTV does support emebdded subs via DLNA. If you don’t see any, something seems to be wrong with your DLNA server. Why not connect wiht network shares which also allows for external subs?

Thanks for the reply.

My question was whether WD TV Live supports external subtitles (i.e. .srt files), not embedded subtitles (if by that you mean embeded in the video container).

I don’t use Network Shares for two reasons:

  1. I was never able to get it to work. WD TV Live does not seem to recognize any files inside my shared folders (“No media to display”).

  2. I want to keep the organization provided by the Mediamonkey library (sorting movies and television shows by actors, directors, show, genre etc.).

rokabard wrote:

My question was whether WD TV Live supports external subtitles (i.e. .srt files)

And I thought my answer on that was pretty clear: it does not. So either use embedded or network shares. “No media to display” is usually a message when connecting via DLNA, not SMB.

I’m still trying to figure out what is going on with this streamer.

I’ve tried a different DLNA server - this time Serviio, and now WD TV recognizes SOME .srt files but not ALL.

(again, all .srt files are inthe same folder as their related video file and have the same exact name)

Any ideas why?

Thanks again in advance.

I’ve had the same issue with .srt files.

I discovered that not all .srt files are created equal.

You have the plain text .srt files, with one line of text and then a CR/LF, and those work.

You also have another kind of .srt file, which seems to have no CR/LF, they just have “;” between sentences, so they look like a wall of text.  My WD does not work with those.

So use a text editor to open your .srt and see what it looks like.

btw, I use either network shares or library mode.

1 Like

You can check with Notepad++ if it’s ANSI and or open and save it in Subtitle Workshop. After that the file should work.