WD TV Live Streaming Media Player - cannot 'see' external subs (.srt)


#1

Hello all.

After much experimentation I was finally able to make my WD Media Player ‘see’ the folders and files I chose to share on my PCs. This was done through Content Source: Media Share. Only problem now is that the external subtitles (.srt file) do not display during playback.

I have read (most) related topics here and I’m still nowhere near a solution. Things I’ve checked:

  • movie filename (.mkv) and subtitle filename (.srt) are exactly the same (I always copy-paste filenames)
  • movie file and movie subtitle are both located inside the same folder
  • tried with short filenames (e.g. Movie.mkv) and longer ones (e.g. Movie_1996_HD_1080p.mkv)
  • Video Options > Subtitle Default: On

Two observations which may yield a clue to someone (definitely not me here lol):

a) .mkv files with embedded subs work as intented (can select subs or turn them off)
b) .mkv files played back from an external USB source (Content Source: Local Storage) also work flawlessly!!!

One last thing to note: I read that I should press the Options button during playback and select the desired subtitle from the menu there. However, my menu on ALL movies played back from my Media Share sources only displays these options:

  • Play Mode
  • Audio
  • Audio Lip Sync
  • Zoom & Pan
  • Post Comment on Facebook>

On the other hand, i.e. when the subtitles are embedded to the .mkv file OR the video file plays from a ‘Local Storage’ (USB), the Subtitles option appears up there normally.

My device is a ‘WD TV Live Streaming Media Player’, firmware version 1.03.10, s/n WNC421620877.


#2

Media Shares aslo known as DLNA … which in most cases (and definately in WD TV case) External Subtitles are Not Supported (Media Shares/DLNA see ‘media’ files video, audio and picture formats. srt’s are basically just a text file … which is not a ‘media’ file)

The problem is documented in the Official WD KBA … https://support.wdc.com/knowledgebase/answer.aspx?ID=5461

There are only 2 Solutions to the problem

  1. As you discovered, embedding the subtitle into the media file will work, and is supported by DLNA/Media Shares.

  2. Use Network Shares … this type of media sharing fully supports External and Internal Subtitle files. External *srt files are fully supported and will 100% display fine.


#3

In ten (10) lines you provided me with not only a solution to my problem but also a thoroughly comprehensive explanation of what was going wrong. This is nothing less than admirable in my book /respect

Thank you very much! I have tested it extensively (varied folder structure, more than 1 PCs, variable filename length, different movie format (both .avi and .mkv)) and it works flawlessly. Again, I cannot thank you enough.


#4

For the record, it worked… for one day lol
On the following day and since then, it fails to detect my shared folders (‘no content’). Either something changed in my network’s settings (I didn’t change a thing ofc) or i don’t know what it can be. What are the recommended media streaming settings on the PC? If I remember correctly, when I got it to work I had ‘Disabled’ on all PCs and ‘Enabled’ only on my WDTV module. It should be of no matter as I’m not using media streaming but just wondering… Should I perhaps turn off media streaming on all the pc’s of my HomeGroup? One last thing: network group in WDTV settings reads ‘WORKGROUP’. Do I need to change that?


#5

For the record, I still haven’t been able to make it work except for that one time. It is driving me crazy - to the point where I’m seriously considering throwing away a (seemingly) perfectly in order device (the WD module) for a new, more compliant product…

Is there maybe some specific port that should be allowed through firewall(s)? This is the only thing that I haven’t dealt with yet.