Image cannot be displayed on WD MyCloud Android app


I just got & setup WD MyCloud. Another thread I was asking about desktop app issue on mac osx yosemite.

And because I also have another issue on android app, I create another thread so the discussion can be focused.

I already setup properly, from my mac I can access the folder via finder (mac file manager). Copying, deleting, etc working fine.

The dlna also working perfectly.

Then I have strange problem with the android app.

I’m using wifi (of course same wifi with the WD MyCloud), I can connect properly browse the files & folders.

But I cannot open images, somehow only some of images can be open with the android app. And strangely I can stream the video properly with MX Video Player.

When I open images it only shown like below:

It states “Cannot access file”.

But if I long press on the files & download it, I can open the image in download section.

Any suggestions?

Thank you

Hi there and welcome to the WD community.

What is the size of this image you are trying open on the application.

Various images from 1224 x 1632 until 2988 x 5312

There are no thumbnail (images & videos), I remember some of first images when I test there’s thumbnail but I cannot find it anymore.

But for the video I can stream it with android MX Video Player

The images can be open only if I choose to download (long press - download).

The photos, video & music tab above always shown no phone found.

Seems like the thumbnail or media type recognation (the indexing/mapping) is not working properly.

Any thought?

Finally I fixed my issue.

I’ve tried several things

  1. Tried to reset the database

I use

/etc/init.d/wdmcserverd reset
/etc/init.d/wdphotodbmergerd reset

and start it

/etc/init.d/wdmcserverd start
/etc/init.d/wdphotodbmergerd start

It recreating the db files in /shares/.wdmc/

But still I encounter the issue.

  1. Then I restart the WD MyCloud via web dashboard

After it’s on I monitor via the dashboard content scan and the log files

tail /var/log/wdmcserver.log -n 100 -f
tail /var/log/wdphotos.log -n 100 -f

Found an error image, so I delete it (not sure this impacting anything, the scanner should ignore the corrupt image and move on)

Then after 1-2 hours I check again now on android app it shown the thumbnails and I can open the images.


I have this problems.
you write solution but I want to ask you.
when do this,  will it be erased all data and photos in Wd cloud?

I nearly have 3.5 tb data in WD and I can’t  back up all files.

No data lost.

On my case seems the working solution is just restart your wd my cloud and wait until it finished indexing.

You can monitor the progress or error with above log files

Hi all,

I believe that the issue is caused from the fact that the NAS has not built the thumbnails.

If you click the HD button, it will download the picture.



how do you re-index?

how do you monitor the progress in the log?

could you please explain where to enter the command to reset the database?

Thanks for this solution, I have the same problem.  However, I need more detain to know how implement it.  Could you provide a step by step explanation for a newcomer?  Thanks.

I am new to WD MyCloud and encounter the same problem; not able to view the picture on Android, but able to do it on IOS.  How can I issue the reset command? via SSH?  

The Content Scan Status is always in the “Building” state (since I bought it last Saturday).  It is always “building thumbnails”, but only one folder (about 30 pictures) has thumbnails, the rest of my photo collection in other folders are not.  They are all in jpg format.  

What can we do to fix these problems?  Thank you. 

I have the same issue. I hope wd hire some good developers and makes a useful mobile application… It makes no sense to have this application if I can’t see my pictures for me.