How to set up iSCSI and windows 10

HI
I have a PR4100, 16Tb RAID 5
It’s just updated to OS5
It’s taking days to re-index.
My question is for when it actually finishes , How do I set up iSCSI and Windows 10 to work.

Do I have to set up both , iSCSI and iSCSI iSNS Client
What information goes into the setup in both.

What do I have to do on the Windows 10 desktop and Laptop to access the iSCSI area…

I’ve done a bit of reading, but to be honest it’s getting beyond me now without a set of samples.
In my 70’s so not as sharp as I was, if I ever was ha ha.
Please does anyone have a fool proof way of setting iSCSI up for use as mentioned.

Or a thought occurs, is it only for windows SERVER machines?
Regards

OK
Looks like not any luck with this question.
Princy557

Hey Princy, kudos for you for not giving up :wink:

This should give you hints you need - skip the mac client setup part. Iti s a bit old but should be more or less the same.

https://www.youtube.com/watch?v=vFc24r9CjyM

Thanks for that,
I’ll give it a shot a little later this evening.
Thanks for the reply, I was beginning to think I’d written in invisible ink ha ha.
I’ve searched before but not seen this one.
Thanks
Regards
Princy557

It does work. Just did it yesterday.

Go to storage and pick iSCSI from the list
Click Create iSCSI Target.
Give it a size and save.

Go to Windows and search for iSCSI initiator.

From there, it depends on how you set up the device and if you want it secure or not.

Thanks all,
BUT, sorry, I still can’t see the drive.
So I tried it on another NAS, Synology… same problem.
I have a feeling I’m missing something on the windows PC, but no idea what it could be.
Anyone any ideas , along with the darn indexing having restarted it’s not been a good time since OS5.
Cheers
Princy557
Edit:::: my mind is not as sharp as it used to be, so I do need leading a bit…

Try this guide.
https://kb.datto.com/hc/en-us/articles/204830776-Mounting-an-iSCSI-Share-in-Windows

The first part is a little different for WD. But where it starts with “Mount the iSCSI Target in Windows” is how to make it work in Windows 10. If you are still struggling with creating a target, let me know if you need it to have a password or not. It not, it is really easy. I can make up some screen shots.

HI jkane113,
Thanks for that. I had not realised that ‘I’ needed to do the registering of the drive, I had thought it might have been automatic, done by windows finding it.
But now it’s working fine just transferring a big bunch of stuff to it now.
Also showing that the extra RAM was being use. (not a lot of it, but enough to show it’s there.
Thanks again, I must try and write this all up before I forget it.
Regards Princy557

Hi corwin_x,
see solution below and explanation of my thickness ha ha…
Thanks for the video, it was interesting. it did give me other thoughts as well as such broadening my knowledge.
Regards Princy557

I’ll try to show the steps. Go to the NAS GUI.

I am a new user. I can only embed 2 pictures at a time. I will spread this out into multiple posts.

Select Storage from the top.
Select iSCSI from the left side.
Click Create iSCSI Target from the bottom.

Enter an Alias. It can only be lower case and numbers. There can be a dash and I think a “.” also. No capitol letters nor spaces.
Set a Size including GB or TB.
If you have more than one volume, you may need to select it. It will select the default one for you.
Look at the Name it gave you. This will come in handy when we get to Windows.
Click Next.
iscsi2

It will ask if you want to add a password. For home use, None may be OK. I am using that for this example to make it easier.
Click Apply.
iscsi3

It will return to the previous screen and show it is creating the Target.

When it is done creating it, it will say “No Initiators connected.”
You can see what you have made, and make changes by clicking on details.

You can make the Target larger, but not shrink it. You have to delete and recreate a new one to make it smaller.
Click Apply if you make changes. Or cancel. You can also delete the Target from here.


Now you can go to your Windows 10 machine and follow the link I shared earlier.
In the Windows search bar, type in iscsi. It should offer the iSCSI Initiator application. If not, you need to install that in your Windows 10 machine.

Here is a snapshot of the iscsi-test target I created above while in the Windows iSCSI Initiator. Following the links directions should work.

Thanks for that, I’ll be back in a few hours got to rush for meeting on Skype…
Regards Princy 557

Hi jkane113
That was just the ticket, Not only that document but all the layout you have just done. Very useful document to have. . I have discovered such a good amount from that instruction , I only hope I can remember it for future use (Yes, I’ll document it too).
I have just tested it and move100,000 + files over and it all worked well.
I also have managed to make my Synology work as well from the same batch of information.
Thank you for all the time you have spent and shared.
Many kind regards
Princy557

Please refer to the below KBA

hi htb WDStaff,
Thanks for the reply.
First off I did some searching the other day on this matter and the suggestion link you have sent was not amongst the answers. I have made a note of it.
Is it possible , stepping slightly off topic, to advise how I can set up another PC or laptop to use the same iSCSI drive.
Note, I’m just about to start another topic to see why my laptop tells me it can’t connect to anything on the PR4100’
Regards
Princy557

iSCSI is not intended to be a shared drive. It is treated like a local drive and the local machine formats it. I would doubt you can mount that drive on 2 machines at the same time.

You would be better off mapping a drive to a NAS share.

Hi jkane113

I think this is what gave me the idea you could. Under iSCSI Target List.

Snap_04 November 2020_21h47m34s_003_

I have also read something in the blur that has been the last four or five days about ‘enabling multiple iSCSI targets’, can’t remember what the actual words were but it implied . As I say it’s a blur, perhaps it was for another of my NAS’s
OK I’m wrong again, wishful thinking again maybe.
Regards
Princy557