Suddenly my iscsi is not working anymore


I bought the WDEX4 few months a go. I created 2 ISCSI drives as targets. Everything worked ok till yesterday. Now I can connect to the regullar drive but the ISCSI coonecion fails. I dontknow why.

I have lots of data but not back up. This is really bad. I really need my data. Is there any way to get the connection back?

Please let me know if anyone has any idea


I recommend you try some basic troubleshooting. Try power cycling your drive and also remapping the iscsi drives.

Hi Hamlet

thank you for your reply. I did try to power cycle the Nas few times yesterday. I also try to remap the ISCSI targets but no luck. What is really bad about this is that looks like I lost about 6 Tb of data. 

I searched on the net but I dont see much info about it.

I still hope to recover it somehow. is the second time something like this has been hapening to me this month. :frowning:


Have you tried contacting support about this issue?

Personal Cloud Support

I called them. I was in the phone **bleep** around for a while and not being able to fix anything, he blamed me for not updating the firmware. I told him that I did yesterday. He told me that that was not was was showing on the system when we started. Well, before that, that sign was not there but the previows person told me to reset the device so I think that is what caused that issue. Any way, I think that was irelevent because the device stoped responding for no reason.

he told me that he will call me tomorrow.

After the conversation, I loget in the computer to browse the other shares, But now they are gone too. And if I tell them tomorrow that they did something to it probably they will not believe me. This is so disapointing.

 :( :frowning: :frowning:

no problem mate

you wil get help anyway  just explain what happened like you did here…  

you seem a very pacific person and i believe your words

please keep updating your thread 

Hi David.

Thanks for the reply

I never had problem before with any WD products. 

I have made a telephone apointment for tonight after I finish my work.

I am hoping to resolve this soon.

I will write here every step till this is solved or …well, lets hope for the best.

If this is a bug created by NAS WD will do the best.

Even if you cant recover your data is still there so dont format.

We can get him back with other tools.

It crossed my mind yesteday few times because i was very upset and because the recovery cost a lot of money. I try to recover before myself but not always with very good luck.

I know the data is still there because I can see how much free space shows. What I dont understand is why? Things looked ok till few days a go. I also want to find answers for me so that I can understand better.

Im unable to understand that behavior

How did you configured your volume ? Raid 0? Mirror?

Tonight I spoke on the phone with a guy from the level 2 support from WD. He try to do the best and I am very happy with him. He managed to bring the normal shares back to life but he was afraid to try anything on the 2 ISCSI disks. He installed a small software on my computer called WinSCP. With WinSCP me managed to navigate to the ISCSI drives and found the images there. They look ok. But I dont know if there is anyway to mount them back so that I can at least back upi my data somwhere else.

Any one has any idea about how to do this?

spapa - This may be an obvious question, BUT I must ask nonetheless. Have you checked if in your dashboard under Storage tab, under iSCSI, the iSCSI switch is set to ON?

Hi Cybernut1

Yes, the ISCSI is on

ok. Yesterday I had a good conversation with someone from Wd that was very skilled. He managed to log in to the device and at the moment my data is transfering to another WD my cloud that I own. Is very slow but I hope it goes on till finishes. Till now I have only about 300 Gb of data tranfered. it will take about 12 days for one of the 2 lost volumes. But I think it is worth it. I hope nothing goes wrong juring the tranffer.

And this morning the pc give me “Running low on disk space” then few minutes after I got this:

System Error.  Code: 112.
There is not enough space on the disk

Any more ideas?

dont you have your my cloud full?

this one is not related:

i have tried iscsi for the entire volume 

i am using 2 disks of 2tb each connected to the ex4

after learning from that document that you passed along i could create that virtual disk drive…

but strangely it appeared as two disks of 4tb each on disk management 

didnt discover what i did wrong  lol

The My Cloud was empty. The reason why it give me error was (this is as far as I understand) when copying. windows copy the information in its memorry before placing it in the new place. In this case I have 8 Gb of ram on this pc. After it filled up the ram, it start placin the data in the local hard drive. I had about 400 Gb of free space in the local Hd. So when that was full, it give up. I think this is what hapened because first I got a message that there was running out of the disk space.

Today I had another telephone call schedduled but for some reason it never hapened. I will email them now and see if there is something to be done.