Highly frustrated

I have a My Book Live and a Mycloud.

I also have a new laptop and my old laptop

I can;t access any of my NAS files on either device.

File explorer sees the two devices. I’ve tried right clicking on them and mount public drive, this just doesn’t work.

I’m reading that a windows update is or may be the problem.

I am reasonably experienced user, but this is now annoying me, that allegedly straightforward devices just stop working.

If anyone can give me a simple plain english procedure to follow, I would be grateful as I have a lot of my stuff on those 2 devices ans can’t access.

Really appreciate any help on this.


@soxer You have posted your topic in the sub-forum for the My Cloud Home.

Here is a link to more information about the My Cloud, 1st and 2nd generation.


What operating system are you using, is it Windows 10? Have you set up everything in the Dashboard and given your devices access?

Here is what I see when I click on File Explore>Network.


Clicking on a share shows me my files.

Thank you for the response. The first thing is the names of my 2 WD NAS drives were showing in the directory tree, then I suspect a recent WIndows update changed something. The devices are showing as icons in the main right hand area of the screen when the tree is on the left.

I tried right clicking on them to mount public share and nothing happens.

Yes it is Windows 10 and I have WD discovery and WD Smartware on the machine.

Most annoying. Keith