Cannot see/access files on My Cloud

I’ve had a My Cloud for many years and having not accessed it for a while,I have come across a problem which might be related to having switched to a new laptop–Hoping anyone can help.

Right now, I can see the WD My Cloud in my network devices and as a location attached to My PC, but when I double-click to open it, I cannot see any files. Tried setting up stuff on the My Cloud website (and I didn’t get a password reset from any of my e-mail addresses, so I don’t think ti was registered to the web before). Ultimately, i seem to be able to see the device through the web interface, and I can see that there are still files on there, but I can’t seem to access them.

I’ve done a reset, but can’t figure out how to access the device as admin, which I assume would let me see my files. I hope. I don’t want to have lost anything.

Can anyone help me:

  1. get access to the files that are there?
  2. figure out the drive mapping so I have the right permission to see them on Windows 10?

I’ve tried the support topics, but so far I haven’t been able to decode the answer. I’m usually not so dumb. Can anyone help?

Hi. Were you able to resolve this issue?

I am able to map the drives and see the contents, but they are read only. I am unable to write anything to any of the drives/directories. I have tried disconnecting and mapping again. I have enabled SMB1 access after the latest Windows updates. Nothing works!

Any help would be most appreciate. Thanks.