Can't access MyCloud with File Explorer

I can’t access it from Win10 and Win8. Used to work a while ago.

I enabled SMB1.0 on Windows 10. This allowed seeing the drive not under “storage” but also in “computers”. Still can’t open.
Can’t map, because there is no such path.
I tried to install the latest firmware, it was installing, then restarted but the firmware is as it was before.
WD MyCloud now doesn’t even detect any drives.
WD Smartware… I have no idea what it tries to do. A moment ago it was telling me I am using 36% of available space. Now 0%. I can’t log onto it. I bought Smartware Pro, now it tells me I can activate it again.

BTW, the dashboard works so slowly I start doing different things and forget about it.

From okayish experience (because it was still unbelievably slow, but worked) now it is just annoying blinking box that uses power and can’t be used in any other way. I can’t even use git with it anymore, since I started to update it.

If anyone has any suggestions, please help me.

But keep for yourself “oh, your wd my cloud predates Windows 10” because that’s an excuse. There are firmware updates, driver updates and other things that should allow it working under Windows 10. I don’t have Windows XP to check if it works but this would be pointless. This is a network drive. It really should not matter. And it has SMB3 support.

Right now I am close to “f that s, let’s buy something else”.

@kotowate What type of router do you have? Are you able to see your device or not under Network? What are the LEDs doing on both the back and front of your device?

Are you able to find the address for the device in your router?

For SmartWare Pro do you still have your activation code?

The router is TP-Link WR841N. Tried different sockets, same result.

I am able to see WD My Cloud Mirror under Network. At one computer I can see it in two tabs “Computers” and “Storage”. Trying to open both has the same result - after a while I am reported with problems accessing the device.

The LEDs appear that the device is idle. 1 and 2 are light up. The up most LED slowly fades in and out.

WD uses static IP address and is not listed in my router. I can access the dashboard via Internet browser by putting that address (and also it works the same when double clicking at WD in Network/Storage)

I have the activation code. I mentioned that it is now deactivated as just another thing that stopped to work :frowning:

I managed to install firmware (2.12.27), didn’t help. I also installed WD My Cloud (v 1.0.7.17). It can’t find any devices in my network.

If you have a My Cloud Mirror you may find better help in that sub-forum.
https://community.wd.com/c/personal-cloud-storage/wd-my-cloud-mirror

Thanks.