Here are 7 reasons why I now wish to use WDMC as an anger management device

I’m an iMac and MacBook Pro owner, plus iPads, MB Air’s, 3 iPhones, Time Capsule, Apple TV 2 & 3 in house… didn’t realise what an Apple victim I was until I wrote that.

Connected iMac to Virgin Media Super Hub 2 router via gigabit Ethernet ports using CAT 5e cable. WD MC connected to router via gigabit and CAT 5e on a static IP. Might as well be connected via a piece of cooked spaghetti though.

    1. WD MC is slow… so painfully and embarrassingly slowwwww. I mean, it’s crazy. If I want to save/access a file directly on the MC, it takes 30 secs of spinning rainbow wheels to open a .pages doc. It’s pathetic. Avg. 5MBps write speed - VIA Gb ETHERNET.
    1. I open the MC app on my iPhone sometimes to dare to watch a film, two things happen:
  • 2a. My WD MC device is offline. Even though its not, but there you go. Cant fix this issue. So the MC just sits there doing nothing for anyone.
  • 2b. After 5 mins or so my shares pop up and I search for the film I want but search returns an error. Search NEVER works.
  • 2c. BONUS ITEM - You see the film, with your heart pounding you click it to watch it and a white screen appears. That’s it. No film, just a white screen with a cute little “done” button in the corner for when you’ve finished watching your screen of “F.A.”.
    1. The browser accessed dashboard now displays NO information! Nothing! No remaining space, no share numbers… its just a nice screen of grey boxes with nothing in them!
    1. Logging into the Dashboard (and every subsequent screen within the DB) takes aaaaaaaages. 
    1. Bought it for its “iTunes server capabilities”. What?? I can have all my media on the MC?? Wow! Oh no hang on, once purchased you find out the **bleep** doesn’t stream video! hahahaha… brilliant. What a con artist that salesman was!
    1. It unmounts from my Macs ALL day long. You mount it, sometime later… it’s gone! Excellent.
    1. BEST BIT - call tech help, get a “lo-call” number to ring beginning “03” from the answer service. In the UK lo-call numbers do indeed begin “03”. But No! What WD meant was “local” as in “the Netherlands” with “03” being the start of the international dialling code for NL! So my 45 min call to them costs £25! Brilliant!!! Your recorded message is in no way ambiguous, WD.

I hate the WD MyCloud. Nothing works, at all. 

If anyone feels in any way inclined to help me address any of these issues, I would be tearfully grateful, tech help advise a system restore. Great. 1.8TB’s of data to now transfer for that to happen.

Is there a better life than this for the owners of these somewhat “mentally challenged” devices?

1 Like

Sorry, there are actually a load more reasons, but I figured that would be enough to make me sound like a complete whinger as it was. I am just fed up of spending my life trying to make this little white box actually work. 

I wont mention that my smart TV cant read it via DLNA. Any other device is fine. But the MC gives me an “unstable connection warning” and then the TV kicks it off. Plus a few other things :frowning:

With a bit of luck, you’ll get an email from support, prompted by the ‘back office’, offering you a refund…

I haven’t raised a single support case, but support have contacted me three times, trying to help.  Which is to WD’s credit.  The last one offered me a refund, when all I had posted was a confirmation of the slow USB transfer rate.  I wonder if they’re trying to get rid of me…

You are indeed an Apple victim, not because you have their products (which in general tend to perform as announced) but because you are trying to use My Cloud with them.

From my personal experience, also being an Apple victim, none of my two OSX Macs (duly updated) works properly with the My Cloud, irregardless of how you are connected (although I feel tempted to try raw spaghetti, just in case). If you monitor your Macs network activity while you are attempting to access folders or files in the MC, you’ll notice a disproportionate amount of data going back and forth while you are left to contemplate the spinning rainbow. For me to access the shared music folder in the public share from any Mac takes more than 3 minutes. In one of the many attempts to understand and solve this problem I tried a full factory restore and migrated only 140 MP3 files to the cloud. The access time got reduced but not that significantly. The paradox is that both from my iOS and Windows7 devices the access is almost instantaneous, irregardless of the number of files in each share (my shared music folder has 70.000+ files).

The same (or even worse) happens if you point your iTunes library to the MC to add the music that you have in the cloud. Each music can take up to some minutes to be added and, meanwhile, the Mac is receiving several Mb of data (possibly all the music file) and sending some Kb.

Since I never saw Apple announcing their compatibility with WD products, I believe that we’ll have to rely on WD to make their product compatible with Apple’s OS…

The My Cloud app only works in the “All” view. From there I can access any folder and file in the cloud, with a pretty decent speed (a couple of seconds tops) both when connecting locally (same wifi) or remotely.

In the “Photos” and “Videos” views I sistematicaly get the error message “The operation couldn’t be completed (WDGeneralNetworkError error 500)”.

In the “Music” view I get the refreshing cloud icon and after some seconds a blank screen…

Regarding streaming via iTunes it just doesn’t work, neither on the Mac or the PC. In both cases I click the icon to choose the cloud library, I get a message that it is reading it and after some seconds it reverts to the local library, without even showing the contents of the MC’s library.

Sorry if none of my posts provides any solution. The intention is just to let you know that the problems you report don’t seem to be related with the brand of spaghetti you’re using for your connections since they are common to many other users, me included. I burned my eyes looking for solutions in all sorts of forums (from Apple to Microsoft, my router’s manufacturer and obviously this one) to no avail…

I have had great experience with WD as a hard drive manufacturer since the 90’s (I commercially assembled custom built computers). I am new to the  community and new to My Cloud. I purchased a 3 TB MC and a 4 TB My Book Studio earlier this month and have had quite a time making it work the way I need it to work!

I spent a few days setting it up to be a single point back up for the household consisting of:

  • Mac Book Pro
  • Apple TV
  • 2 iPhones
  • 2 Windows 7 computers
  • 3 Linux computers

I intentionally disabled remote access from outside my house due to security concerns.To start with I disabled all media sharing.

I easily set up the MBP for TimeMachine backups and the desktop MyCloud access. I insured safepoint was being correctly updated. Iwas able to use Smartware to backup a Dell Laptop running Windows 7. All this was relatively fast. However the automatic safepoint updates were taking 3+ hours. Level 1 tech support said this was entirely too long and suggested that I reformat My Book. Well after much hunting the proveribal wild goose:wink: I actually discovered there was a time difference caused by the Debial MC kernel not reflecting the actual time set using Dashboard.

I ran into real “problems” using Smartware to backup my HP desktop Win7 computer with an internal SSD and an external SATA 1 TB. Bottom line I think these backup caused safepoint corruption that necessitated the safepoint deletion. I’ve opened a case with level 1 support, that was escallated to level 2 withing 5 minutes and that has been escallated to engineering after a 30 minute discussion. I’m waiting for resolution. I’ve decided that since the documentation does not support defining all the event codes that I will wait for engineering to respond and not try to implement other functions of the solution!

I have found these 2 WD devices to be fast in my setup. So far they are also extremely limited in scope. WD, IMO, is struggling with consumer grade solutions. I hope to obtain guidance from engineering on how I can best use my new setup!

Thanks for the comments and shared stories, it’s interesting to see what other’s experiences are like. 

I got a call from Tech Support today, as always very polite and helpful, but no real solutios were uncovered. Log files have been requested, whether it leads to a solution is another question.

In the meantime 1 of my shares has become unmountable. Tech support advised changing the permission back to public, then back to private again. I attempted this, the “updating” message was there for around 15 mins, then an error message popped up. After that the MC became totally inaccessible via my browser. I am restarting it again as we speak.

Can’t even manage a share without it cr*pping iteself :confused: Just more of the same really. It doesn’t work.

" Avg. 5MBps write speed - VIA Gb ETHERNET."

My average is 90MBps on large files [above 2GB],  I have obtained as much as 108MBps

Be aware that small files in bulk will always have a slow transfer rate. I have some website backups with over 10000 files smaller than 1MB each and it I was getting only 1MBpb max  …Slow rates on small files is the norm for any transfer with any gear.

Make sure all you cables are Cat6. I had a Cat5e cable in my chain and was not able to get over 65MBps in any circumstance, as soon as I changed it to Cat6 I was getting the 90MBps as average. Alo make sure you don’t have any Cat5 cable in your chain and that any switches [or Routeres] are all Gigabit. Some “inexpensive switches” from 8-10 years advertised Gigabit but were only Fast Ethernet.  My current switches are all cheap Trendnet’s so no reason to spend a lot of money…

Judging by the rest of your issues you may have a “lemon”. I now have 2 of these WD Myclouds and have not had any of the issues you mention. Hopefully you get a warranty replacement.

Do you know, I hope I do have a lemon. It would be awesome to find out this product does actually work. 

I have done a few drive speed tests on it and they avg 30-50MBps, however recently when I ran the test I was only getting 5-10MBps. I don’t know what changed but 30-50 is better than 5.

Its still slow though, slow to access, slow to loads screens and so on.

A new one for the mix - if you open up the MC desktop app, it will open then a few seconds later say “No WD device was found on your network”. Then it continues to work. 

Just another little foible. 

I thought I’d provide an update for you on this case. 

  • 2 weeks ago - posted this thread
  • 18th March - got email from WD Support offering to help and requesting my proof of purchase and log files
  • 23rd March - located and sent them my proof of purchase and log files
  • 25th March - sent across MyCloud log files again as “not received” the first time
  • 30th March - received email from support telling me the issue relates to a connected USB drive and to remove it, reboot and then restore if the device is still utterly sh*t. I advise them I do not have a USB drive connected to the device, which I actually do not. I plugged one in once on the day I bought it 1.5 months ago, but I have not had a USB drive connected to it since. I think it’s amazing that a non-existent USB drive can be highlighted as the cause of the MC’s rubbish behaviour.

I estimate the time I’ve spent dealing with this awful device’s problems must be 10-12 hours, at least. It still remains one of the worst devices in my house, and that I’ve ever bought. The support guy is very kind and helpful, but I have to question the sanity of the team there when they are blaming the MC’s poor performance on a device that isn’t actually in existence. 2 weeks to get to that too.

I plugged one in once on the day I bought it 1.5 months ago, but I have not had a USB drive connected to it since.

Did you eject it before you unplugged it?  If not, the MC might think it’s still there.

Whilst it might be nice if the MC detected that the USB had been unplugged, it would also be good practice to eject before removing.  Not that you’ll find an entry in the User Manual index on how to eject a USB drive safely (for reference: it’s on the Dashboard; top right ‘USB Symbol’; click on this, and then click on the blurry ‘eject’ button (a rounded triangle on top of a rounded bar)).

I estimate the time I’ve spent dealing with this awful device’s problems must be 10-12 hours, at least.

As little as that?  Wow, you’re doing well…

Sorry, to many things. I write it in Russian.

  1. Да, девайс безумно медленный и WD использовала все доступные костыли, чтобы выжать из него максимум. Отчасти это удалось, принеся в жертву совместимость с “Номарльным” софтом (PageSize=64kb против стандартных 4kb)

  2. На родной прошивке девайс зависает намертво (Отваливается от сети) стабильно раз в 3-4 дня, а то и чаще.

Удивительно, но чистая система работает стабильно месяцами с полным набором софта и нагруженная по самое немогу (Торренты, сетевая шара, MiniDLNA… Я даже ядро системы и некоторый софт на нём собираю в 4 потока! Хотьбы раз завис!)

3, 4. Веб интерфейс часто “Ломается”. То место не показыает, то ещё чтото. Написан он вообще через одно место (Крайне криво, зато красиво…). Внутри системы не лучше - костыль на костыле костылём погоняет.

Альтернативаы в лице OpenMediaVault или WebMin работает на порядок стабильнее, не говоря уже про функционал.

  1. Для транскодирования у девайса маловато мощей. Хотя да, есть поддержка Neon, что значительно ускоряет работу с мультимедиа. Но всёж на FullHD не хватает :frowning:

  2. Это из-за отвала устройства из сети. (пункт 2)

Да, сэкономили на всём, что тут скажеш.

Но, блин, могли бы и хоть немного постараться! Девайс способен на большее!

Rough translation - Trancer

  1. Yes, the device is incredibly slow and WD has used all available crutches to squeeze the maximum out of it. This is partly managed by sacrificing compatibility with “Nomarlnym” software (PageSize = 64kb against standard 4kb)

  2. On the native firmware device freezes hard (to fall off from the network) consistently every 3-4 days, and even more often.
    Surprisingly, the net system is stable for months with a complete set of software and loaded on most can`t (torrents, net ball, MiniDLNA … I even core system and some software on it was collected in 4 threads! Hovered just walk!)

3 and 4. The web interface is often “break”. That place is not pokazyaet, something else. He wrote all through one place (extremely crooked, but nice …). Within the system is not better - a crutch crutch crutch chases.
Alternativay in the face OpenMediaVault or WebMin works much more stable, not to mention functional.

  1. transcoding devaysa little relics. While yes, there is support for Neon, which greatly speeds up the work with multimedia. But even so on FullHD not enough: smileysad:

  2. This is because the dump device from the network. (Paragraph 2)

Yes, save on everything, what can I say.
But, **bleep** it, and might even try a little! The device is capable of more!

10-12 hours - I am probably being conservative :wink: Did I say hours? I meant full days :wink:

Even if I hadn’t ejected it (not that it would be a suitable excuse), I have rebooted it God knows how many times. I wouldn’t expect a device to think it still had a USB drive attached after a reboot where no USB drive exists. The dashboard certainly doesn’t think a USB drive is attached, it happily states “No USB devices found”.

Thanks Fox. 

If only I spoke Russian.

One more thing - Full reset takes ~20-30 hours…

Also there is no easy way for restore device (Reset button not work if OS/RootFS damaged).

Only one “Backdoor”, but only for professionals and need additional software and recovery image… brrr…

Ps: I make linux-kernel v3.2.68. Its includes xhci fixes - USB work perfect now, I upload it later.

20-30 hours to restore? Sod that. Seriously. Time for a refund if we get to that stage.

a full restore should only be used to get rid of the mycloud. it is slow as it writes multiple patterens over the entire drive to prevent recovery of data

 I wouldn’t expect a device to think it still had a USB drive attached after a reboot where no USB drive exists

I think I’d agree with that…

I’d want the full factory restore to delete my data if I were to return or sell the device.  Even though I don’t put anything sensitive on it…