Help required - WDMyCloud showing everywhere but will not connect via local network

I’ve been on here for 2 days trying to make this work. I’ve followed every instruction (including 1-5 & 7 on the Windows 10 trouble shooter compilation) but I still can’t access the drive through Windows Explorer.

I need to access a couple of files in the SmartWare backup that I can’t access any other way.

I recently changed router. It was working before the change.

NetBIOS over TCP/IP is enabled.
Network is set to Private.
Network Discovery and File Sharing is enabled.
The computer is connected to the same router as the My Cloud (WD ethernet, PC WiFi).
The correct credentials are saved for both the IP address and \WDMyCloud.
I’ve reserved the IP on the router and set the IP to static in Dashboard.
Port Forwarding is working.
I tried mapping the drive.
I tried logging in with different credentials.

I can access with IOS.
I can access Dashboard via web browser using the IP address AND WDMyCloud/UI.
I can access some files through the WD website.
I can see it on WD Quick View.
I can see it on WD Access.
I can see it on WD SmartWare but it won’t login.
I can see the drive in ‘Network’ AND under “Computer” after changing SMB to on but when I try to connect it still gives me “Windows cannot connect to WDMYCLOUD”, etc.
I’ve tried to access the drive on my son’s brand new laptop and I get the same result.

On my Device manager there are 2 instances of WDMyCloud. On my son’s there is one. I deleted both but 2 instances came back. Not sure if this is relevant.

Strangely enough, my Synology is working perfectly.
This has cost me another few days of my life - Thanks WD !

Any other ideas greatly appreciated.


Can you post a screen shot of the actual error message (or type out the specific error message) you are receiving in Windows when attempting to use Windows File Manager to access the My Cloud drive.


Couple of suggestions. One ensure you either reserve the My Cloud IP address within the router OR set a static IP address within the My Cloud Dashboard. Don’t do both. If reserving an IP address within the router, set the Network Mode to DHCP within the My Cloud > Dashboard > Settings > Network.

Second, if you haven’t tried already, try accessing the My Cloud using it’s IP address. Example in Windows File Explorer: \\

Thanks Bennor,

Originally, just the WD was set to static, then I also set the router. I have now tried it 3 ways - router individually reserved IP, WD individually set to static IP, and both set and now back to just the WD set to static.

Also tried the IP in Windows Explorer. Different error this time - 0x80004005 - Unspecified error (could be named Unhelpful Error)

There’s obviously one setting somewhere in all this that is causing this. Makes me crazy.

As a troubleshooting step, check any security/malware/antivirus software on the computers to ensure they are not blocking local network access to the local network My Cloud.

And as another troubleshooting step, if the computers are connecting to the local network router using WiFi make sure WiFi Client Isolation isn’t enabled on the router.