Help - Only Admin can access shares? (solved see link)

8TB My Cloud EX2 - All Machines Windows 10 - Looking for some support - When trying to access network shares not set to public, only the admin user can actually do it from the file explorer. When I try to use another account set up, with access, it prompts me for credentials, and then when I enter them “access denied” - I do know the password/credentials are valid because via the mobile app and web log in they can access the NAS. Apologies is this has been asked a million times but I can’t seem to find it - it seems totally silly that users couldn’t access the shares via drive mapping/file explorer so I know I’m doing something wrong.

I found this is the support " My Cloud: Use the admin username or any user on the My Cloud with read/write access to a password protected Private Share." so to put it simple - for me, admin works “any user on the My Cloud” dos not…

It’s universal across all my machines - public can be mapped, other folders can be seen but get denied unless logging in as admin - what am I doing wrong? Help!

Ok while researching I found this great post (linked below) - although it speaks in the magical wizard language of people who can read logs and use fancy acronyms, I basically just deleted the groups (didn’t really need them) and presto! My private shares worked to map.