Hello New User With Issue Playing MKV file?

I have read and i know the issue about the MP42 is not supported (IDK how it works but hopefully that will be added in a firmware update?) I have had this device for about a mothn now ( WD Live SMP) although setting up my network storage kept me from using it untill about a week ago. Since then I have been able to play MOST files. Never have i gotten an Error telling me the file will not play. although some files like the one i am talking about now when I load it up IDK whats going on as the player I have Never gotten an error message for any file. Instead this file i think opens but then i get a blck screen. (no menu bar on bottom of screen nothing, although i am able to stop it and go back to my video folder.) So its not crashing the device. SOOOO anyway here is the media info on this file can anyone find anything that would be keeping my player from playing it correctly??

Format                                   : Matroska
Format version                           : Version 2
File size                                : 1.17 GiB
Duration                                 : 55mn 16s
Overall bit rate                         : 3 029 Kbps
Writing application                      : x264.exe
Writing library                          : mkv2rls x264-tv version built on 2011. febr. 17

ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L4.1
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 5 frames
Codec ID                                 : V_MPEG4/ISO/AVC
Duration                                 : 55mn 16s
Bit rate                                 : 2 585 Kbps
Width                                    : 1 280 pixels
Height                                   : 720 pixels
Display aspect ratio                     : 16:9
Frame rate                               : 23.976 fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.117
Stream size                              : 1 022 MiB (85%)
Writing library                          : x264 core 122 r2184 5c85e0a
Encoding settings                        : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x113 / me=umh / subme=8 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=36 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc_lookahead=50 / rc=crf / mbtree=1 / crf=18.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
Language                                 : English
Default                                  : Yes
Forced                                   : No

ID                                       : 2
Format                                   : AC-3
Format/Info                              : Audio Coding 3
Mode extension                           : CM (complete main)
Format settings, Endianness              : Big
Codec ID                                 : A_AC3
Duration                                 : 55mn 16s
Bit rate mode                            : Constant
Bit rate                                 : 384 Kbps
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 48.0 KHz
Bit depth                                : 16 bits
Compression mode                         : Lossy
Stream size                              : 152 MiB (13%)
Language                                 : English
Default                                  : Yes
Forced                                   : No

Check if you have the latest firmware.

1 Like

I posted an issue about this on the issue page, I also posted here in case users can help me out. (possibly faster or myabe someone has had similar problems) Lastly, if any more information is needed please dont hesitate to ask! I am a new user with this product although I believe I am fairly knolegeble about this stuff in general so I got a feeling I will be able to understand you but just in case I am a newbie with this device. Anyways thanks for the reply kudos.

This is what I posted on the issue page:



Which firmware?



What happened?

     Video Does not fully load. Loads Video Shows me File Legnth as 00.00.00 and video controllbar with black screen sits thier. Most of the time I can press stop and it goes back to my video menu although it shows a Orange cirgle with arrow (thinking icon), Other times it requires a system reeboot.


What were you doing?

     Trying to view a Video File on my WDTV SMP


Does this happen every time?



What hardware and media were you using?

     Network Shared USB Drive, connected via USB to router connected with cat5 gigabit wire to WDTV SMP. Windows Media Share Connected Wirelessly (N) to to Router Connected to WDTV SMP via cat5 gigabit wire.


Did this happen with previous firmware?

     I just Purchased this device and the first thing the device did was update its firmware to the current firmware.


Does power cycling the unit solve this?

     No, although it is required sometimes to get the player working correctly again.


Does resetting to factory defaults solve this?



Have you tried this on other devices?

     Yes, it works just fine on my PC


Any Ideas As to Why .MKV files dont work on my WDTV SMP??? I had an issue with MP4 files as they would play as songs until i decided to name them .mpg (as they are mpeg-4 encoded) well i believe this tolfd the player this file is in fact a Video. Although i still have no idea how to fix this MKV thing. I am A brand New owner and so far half of the files i was hoping to play with device does not work :angry: Right now i am at a loss as to what to do I wish people could make custom firmware to fix thesed problems. Then we would have a community of users making the product better and better instead of a few guys changing stuff every once and a while. 

Right now i have 2 issues that are (in Review) for a while now and i feel as if they will never be solved. I think i am going to Try and Revert my firmware if its possible. As When i first plugged in the device it updated to the current firmware. Or I would start at the first firmware then keep updating untill what i want to work does then stop the updates. All i use this for a way to view my video content off my central storage. I have no real need to watch youtube on my tv nor any of the other things on thier that require you to go to a pc and regester before you can even use it. Sorry i feel like im off topic now.

All I can say is that MKV and MP4 files DO play, as long as they’re ligitimate and correctly encoded, and within the specs of the player.

I have thousands of MKV files that all play correctly.

[/share] # find -name '*.mkv' | wc -l

2,373 of them to be exact… 

MP4 videos also work fine for me; I have several hundred of those.

How are you encoding your files?

1 Like

All my MP4s are encoded with MPEG-4 video and AC3 audio and all my MKVs are AVC X264 Video and AC3 audio so I just don understand what setting i have wrong. I download some and encode with VirturalDubMod and just use the general settings. If someone can point out what is wrong with this file I would like to know? I am thinking today i will revert my firmware to which IDK maybe an old one and online update from thier? Untill I find one that works or find that it will not fix my problem. so far my issue has been up for about a week and i have heard nothing back from  WD except that first i did not format it correctly then to tell me it was in review. Personally I dont get it this is the first WD product i have purchased that did not work flawlessly out of the box. I normally hold WD in High regards the hardware they make is stellar but the sofware… IDK i just cant find a reason why i cant get this file to work. From all the reading i have done this thing should play anything and also it is a Gen3 SMP too