HDD waking up from sleep every hour

Device wakes up from sleep every hour : We have been able to reproduce the issue and are investigating the issue. We will provide a fix in a future release.

1 Like

Same here. I checked the system extended log, My purple waking up from sleep every a quarter of an hour. Mostly no sleeping after upgrade 5.05.111.

The same behavior. My NAS is by my bed. So it keeps waking up during the night and wakes me up constantly. Extremely annoying. Please fix it ASAP.
No indexing, all the services are disabled.
My Cloud Ex 2 Ultra
OS 5.05.111.

Have the same issue. Indexing finished several days back, no apps are installed and even the one PC which uses the network drive is switched off. Can’t figure out why hard disks keep getting awake even at night and then go back to sleep at such short intervals. Any help is appreciated.

2 Likes

Even Power Saving configuration doesn’t help to workaround the issue! It’s very serious bug - it will kill HDD in a very short period.

I used ssh to fix most of my problems. Typing crontab -e and putting # in front of all the lines inside of there helped me. restsdk.sh stop and otaclient.sh stop (i believe. not at home so can’t check the exact command). I then used the “top” command (q to quit monitoring) and typed kill (or kill -9 & pid number) pid number for the sql and rogue ota processes if still running or other stuff running i didn’t need. Apache2 i wasn’t able to kill but i believe that’s for the web user interface so rather necessary. Be careful stopping processes you don’t know what are.

Lastly i deleted (rm) /etc/nas/wdlog.ini and (/usr/local/config/wdlog.conf. Remember to backup these files before you do (cp command, mv to recover from .bak f.eks.).

Remember to undo all of this again if you need to reboot just too be on the safe side although i think the crontab get’s reset then anyway.

Using samba i did initially have some issues with an extra smb -d process running wild but killing it (kill pid/stop-start samba) and rebooting my client pc and resetting samba on there as well seemed to stopped it from doing what ever it did to my first drive on my pr4100. I can’t get nfs working now but maybe in a future update.

I know it’s messy and i wish wd would fix this. :confused:

2 Likes

Thank you very much for your efford!

I did only some of your commands, which are letting the HDDs sleep on my EX2 Ultra:

  1. random_chk_central -d
  2. crontab -e (first command is changing the crontab, so doing it afterwards
  3. set_pwm clean (not sure that it does anything, but as you mentioned, only parameter working with set_pwm
  4. restsdk.sh stop

The drives are sleeping now, altough the user.log is full of error from WDLogUploader and getAgreement. But i don’t mind, WD should fix the problem anyway.

You are right with the reboot (or firmware update), all changes are gone and the crontab is default, so you have to do it again afterwards.

2 Likes

About the wdlog errors. That is why i wrote in the “#” before all of the configs inside of the crontab -e. I believe it’s the “PullWdlogConfig” setting and maybe also the “Rotatesyslog” that’s the most important here. Im not at home so can’t check so the names may be way off. haha. :smiley: Not sure you need to delete the wdlog.ini and wdlog.conf but i just got tired of it all so i did that as well. Nothing bad seem to happen doing all of this. Oh and remember to save the crontab or other files you change by hitting “Esc” and then typing “:wq” (save & quit) and hitting enter or else the changes won’t be persistent. When editing files you need to type “i” before you can start to write inside it. Some sh files are read only and nothing i’ve tried has changed this. The CleanAlert.sh error also i think is still there but it’s not shown that often.

The set_pwm clean i did and it seemed to be related to the spinning up & down of the drives as well as maybe the fan. Maybe it resets it somehow. Not much documentation on the commands. The user.log and also by reading the files it mentions (vi) hints at the files related to the errors.

If some wd program is installed on the windows pc it’s also best to uninstall that so i doesn’t try and communicate with the box.

Also it’s never been a complete fix just something i messed around with on my own. :slight_smile:

My Apache2 process runs at around 14% but all the others almost idle.

I properly missed a couple of configs inside of “/usr/local/sbin/” (“ls” to list files) & hitting the tab key twice . But looking for something with “log” in the name or from the “top” monitoring im sure covers most of them.

But the most important of it all seem to be the “restsdk.sh stop” command. :slight_smile:

1 Like

Thank you to you and Rumaben! By the way, editing crontab in vi is terrible. :unamused: The workaround works fine so far. But of course we’re looking forward to complete solution from WD. Maybe your workaround will allow our HDDs to survive while waiting the solution from WD. :slight_smile:

1 Like

Let’s hope there comes a proper solution soon.

1 Like

Well i rebooted and found a few other stuff hugging up resources. mysql which i turned off by “mysqladmin shutdown” (mysqladmin -help to show options), “upnpnas.sh stop” & “otaclient.sh stop”.

Type in “load_module” to start them up again. (even the restsdk-server).

nasAdmin.sh is the one enabling being able to go to the wd html page (and i think ssh also) so should not be touched. “random_chk_central -d” doesn’t seem to change the crontab. sprite-wdhw & BNFA-thermal im sure is not a good idea to kill.

All is reset on reboot.

Reboot? What are you talking about? I even stop breathing near NAS! :grinning:
So far so good. At least till I don’t have power outage. :smirk:

2 Likes

Hahahaha, computer software helping people getting gray hair and bad backs since 1943. :smiley:
Nice one. I know i’ve been spamming this site to much lately mate. :slight_smile: I just hate it when stuff doesn’t work the way it should.

This is how it looks before “restsdk.sh stop”, “mysqladmin shutdown”, “upnpnas.sh stop” & “otaclient.sh stop”:

And after:

httpd/apache i’ve been unable to stop even though both seem to the the option “stop” in the parameters but it just lists the help text.

All is great although my samba 3 speed seem terribly slow after the “OS update”. Maybe it’s just some config im missing although the smb.conf show that v3 is enabled (shows v2 in ubuntu but might be a bug).

Maybe someone can explain to me what mysqld, apache/httpd and otaclient is used for on the mycloud? Im thinking database and webserving but how important are they?

Edit: Found another cronjob at /etc/cron.d. The PullWdlogConfig.sh line was moved from /var/spool/cron/crontabs (or maybe just dupe) maybe because of firmware update or because i deleted PullWdlogConfig.sh before last reboot. Anyway anything deleted at “/usr/local/sbin/” gets reinserted after a reboot. I believe they’re just symbolic linked shortcuts from “/usr/local/modules/localsbin/”. Found the " killall crond" command as well but not sure if it did something. The errors as well can be eliminated by deleting matching error sh file inside “/usr/local/sbin/”. Right now im testing if the user.log spinup/down keeps running even after 3 days when disabling all the cron configs with “#”. wdlog.conf is safe to delete but the wdlog.ini i think not, at least if you want to keep the user.log activity (stops running after a few days i think). The latter two gets imported again after a reboot im pretty sure…at least after a firmware update.

Also playing with scaling governors, swap and cache pressure now as well. Some nice guides:

https://www.kernel.org/doc/Documentation/cpu-freq/governors.txt

Edit: Trying these settings at the moment:

echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor (default is performance)
echo performance > /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor (")
echo performance > /sys/devices/system/cpu/cpu2/cpufreq/scaling_governor (")
echo performance > /sys/devices/system/cpu/cpu3/cpufreq/scaling_governor (")
sudo sysctl vm.swappiness=10 (default is 60)
sudo sysctl vm.vfs_cache_pressure=50 (default is 100) (i have 16gb so maybe skip this with 4gb)
echo always > /sys/kernel/mm/transparent_hugepage/enabled (“always” can be replaced by “madvise” or “never” to disable). (default is “always”)

2 Likes

You provide a solution despite WD! So thank you!
I’m sure you deserve to spam here as much as you need. :upside_down_face:

1 Like

So any simple solution for normal mortal human? I hate this stupid wakeups!

I have MyCloud EX2 Ultra.

Enable ssh and ssh into your mycloud:

Windows/Putty: sshd@mycloudip (into Host Name (or IP address) (Port 22) (SSH)
Linux: ssh sshd@mycloudip (terminal)

Type in your password.

Then type ‘restsdk.sh stop’ (‘mysqladmin shutdown’ maybe as well). It should stop indexing so much although yours look rather aggressive. :open_mouth:

The next stuff is just suggestions and properly not needed if you don’t like to mess with it to much. :slight_smile:

Evt. check what’s going on by typing ‘vi /var/log/user.log’ inside of the mycloud. Or ‘top’ (‘q’ to quit). typing ‘exit’ will logout.

A user in this forum found it also was related to a cronjob. Type ‘crontab -e’ to enter editor and put in # in front of a line like so:

#0 */4 * * * /usr/sbin/rlog -s /usr/local/modules/files/syslog_rotate.conf

Although i panicked and inserted # in front of it all both with ‘vi /var/spool/cron/crontabs/root’, ‘vi /etc/cron.d/wdlog’ and deleted the stupid sh shortcuts files inside of ‘/usr/local/sbin/’ (using f.eks. ‘rm /usr/local/sbin/PullWdlogConfig.sh’) (PullWdlogConfig.sh, getAgreement.sh, wdLogUploader.sh, cleanAlert.sh and /usr/sbin/rt_script.sh).

Other files that can be either #'ed or deleted ‘/etc/nas/wdlog.ini’ (the latter might stop the user.log from running after a while) and ‘/usr/local/config/wdlog.conf’.

1 Like

Latest update too didn’t fix this issue. When will this issue get fixed @WD_Admin?

3 Likes

It’s been 2 weeks since this issue was identified and reproduced by WD staff, can we please sort this out else HDD’s will definitely have their life reduced with constant spin-ups and spin-downs. I barely use my NAS for 2-3 hours in ~30 min intervals but it keeps busy throughout the day.

In the short term, is there any particular setting or activity that causes this (which you could reproduce and we can potentially avoid)?

1 Like

Unfortunately there are no settings to fix the issue but editing internal scheduler using SSH. And only till next reboot. Sorry. If you can’t use linux console you have to wait a WD fix.

Editing the internal schedule (crontab -e) is working only for few hours. Indeed it comes back to its usual config automatically… and I don’t know why. I tried to disable (comment) all lines in crontab without success.